libtool
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Libtool] RE: Can't install CVS libtool


From: Bernard Dautrevaux
Subject: [Libtool] RE: Can't install CVS libtool
Date: Mon, 18 Sep 2000 20:31:00 +0200

> -----Original Message-----
> From: Gary V. Vaughan [mailto:address@hidden
> Sent: Saturday, September 16, 2000 3:47 AM
> To: Bernard Dautrevaux
> Cc: Libtool Mailing List (Adresse de messagerie)
> Subject: Re: Can't install CVS libtool
> 
> 
> On Fri, Sep 15, 2000 at 08:08:31PM +0200, Bernard Dautrevaux wrote:
> > Hi all,
> > 
> >     I'm trying to install CVS libtool in my environment and, after
> > several attempts, I have to request some help.
> 
> Oops, my bad.  I hadn't tried a VPATH build since I removed ltconfig.
> I checked a fix in earlier this evening, maybe it will help.
> 
> > The problem is that although ltmain.sh is created 
> correctly, the libtool
> > script is created using the installed version of libtool :-(
> 
> It sounds like you have an aclocal with the previous version of
> libtool.m4 or something.  Make sure to run the bootstrap script in the
> source tree after major changes like the ltconfig patch...

I had already check that; the start of the aclocal.m4 generated by bootstrap
in the source tree is exactly (except for the aclocal-added header and the
"##" comments removed) what is in libtool.m4 :-)

> 
> > I've verified there is no old version of libtool in 
> $srcdir, nor $srcdir/..
> > or above and I don't know why configure creates a libtool 
> script using the
> > installed ltmain.sh instead of the one it just created
> 
> Nor I =(
> 
> > Any Idea of what I could do (short of backing up to the 
> installed version) ?
> 
> Post a report here, and wait for me to fix it =)O| Failing that you
> could try a build in the source tree and see if that helps.

I just do that, but it does not help. BTW I'm using CVS automake and CVS
autoconf.

However I think I have some more clues on what is happenning:

I get the CVS libtool files in some directory; the parent directory contains
various config files (liek config.sub, config.guess, install-sh etc.) but
*not* ltmain.sh not ltconfig.

Then I run "./bootstrap", gets some warnings (from "configure.in: 8:", 10,
16 or 33 about AM_PROG_LIBTOOL being obsolete and from "automake: .am:"
about ├Čnstall.sh' being an anachronism) but this should not cause problems. 

However what *does* cause a problem is that now there *is* an ltmain.sh in
the parent directory! then when starting "make all" make correctly build an
ltmain.sh file in the current directory (I've reverted to build == source to
try to sort out the problems) but config.status will use ../ltmain.sh
(instead of ./ltmain.sh) to build libtool (as ac_aux_dir was set to ./..)
?-(

What I does noext is getting the libtool source tree in a subdirectory of
some empty directory; now ./bootstrap will no more create an ltmain.sh in
the parent directory; However I still get the previous warnings, as well as
the following one when calling autoconf in the sub-directories (libltdl,
demo, depdemo, mdemo and cdemo):

        configure.in: 26: required file `./ltconfig not found'

I'm not sure it's relevant but the line number was always 26...

At this point there is no ltmain.sh neither in the parent directory (still
only containing the 'libtool' directory) nor in the top source directory;
however there is an ltmain.sh file in each of the subdirectories (and this
is an old one, from my installed libtool-1.3.5)...

After that if I call configure, when calling configure in libltdl it dies
when starting to run "/bin/sh ./config.sub"; quite normal as config.sub is
in the to source directory and we're in libltdl ;-|

Now I have in the top source directory a file named "ltconfig" which was
generated quite correctly and contains the timestamp for CVS libtool and a
libtool script which is this ltconfig file concatenated with the ltmain.sh
file from the installed libtool-1.3.5   8-0)

Looking at what happens is there was config.sub and config.guess files in
../..! that triggerred the install of an ltmain.sh there (by automake or
autoconf I think) which was used to create the local libtool and confuse
configure :-(

Then I moved to a totally fresh source tree, with nothing above it for two
levels at least, and all seems to start OK now :-)... I was able to "make
all" and now I'm "make check"-ing and I'me seeing the happy "PASS" messages
till the boloved "All 83 tests passed" :-)

Needing to install in a totally fresh environment is a bit frustrating (as I
maintain all the tools I use in an integrated source/build tree) and I think
this should be corrected before getting the release out (probably by
including all the needed scripts in the distribution). 

However to avoid others losing days trying to install the CVS version, I
think a prominent notice in the install instruction (or even a test in
"bootstrap") would be a great enhancement. 

Regards, and thanks a lot for bringing us libtool!

        Bernard

--------------------------------------------
Bernard Dautrevaux
Microprocess Ingenierie
97 bis, rue de Colombes
92400 COURBEVOIE
FRANCE
Tel:    +33 (0) 1 47 68 80 80
Fax:    +33 (0) 1 47 88 97 85
e-mail: address@hidden
                address@hidden
-------------------------------------------- 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]