[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AC_LIBTOOL_CXX and ltconfig

From: Dave Morrison
Subject: AC_LIBTOOL_CXX and ltconfig
Date: Tue, 05 Jun 2001 17:06:38 -0400
User-agent: Mozilla/5.0 (X11; U; Linux 2.2.18 i686; en-US; rv:0.9+) Gecko/20010531

Hi all,

I have a `hello world' project written in C using the HEAD revisions of autoconf, automake and libtool. When I run configure, it ends like this

creating libtool
checking if libtool supports shared libraries... yes
configure: creating ./config.status
config.status: creating Makefile

and everything is happy.

I have another `hello world' project, this one written in C++. I use the same revisions of the GNU build tools and when I run configure, it ends like this:

checking dependency style of g++... gcc
./ltconfig: ./ltconfig: No such file or directory
configure: error: libtool tag configuration failed

I've tracked things down to AC_LIBTOOL_CXX which tries to run ltconfig (which no longer exists after the recent merge into libtool.m4). If I comment out the guts of the macro, everything configures, compiles, links and runs fine. Is it fine? I'm guessing that this is just a nook of libtool that just hasn't quite recovered from the demise of ltconfig. Is that a correct assumption? I see the same use of ltconfig in AC_LIBTOOL_GCJ, by the way.

I'm happy to contribute a patch which comments out the bulk of AC_LIBTOOL_CXX, though I seriously doubt that'd be the right way to handle this. Is there a better way at the moment to handle this?


David Morrison  Brookhaven National Laboratory  phone: 631-344-5840
               Physics Department, Bldg 510 C    fax: 631-344-3253
                          Upton, NY 11973-5000  email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]