[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: passing flags to the librarian

From: Duft Markus
Subject: RE: passing flags to the librarian
Date: Wed, 12 Dec 2007 08:38:08 +0100


You may wanr to have a look at parity
( It was written more or less to be
more powerfull than cccl (but for now is only tested with interix, not

Also parity comes with a patch for libtool to behave nicely, and i also
have a bunch of patches we required to be able to build pcre (on other
systems too, not only windows) - i attached them here (apply in source
directory with "patch -p1 < patchfile").

Hope that helps.

P.S.: have you tried ARFLAGS='/LTCG'?

Cheers, Markus

David Byron <> wrote:
> I'm building a libtool-based package (pcre) using Microsoft command
> line tools in a cygwin shell.  I use a wrapper script for the
> compiler and linker (cccl), but the librarian (lib) gets invoked
> directly. 
> I'd like to specify the /LTCG (link time code generation flag) to the
> librarian.  Beats me why I need it, or what it actually does, but
> when I compile source with the equivalent option (/GL), I get this
> warning from the librarian if I don't have it:
> /bin/sh ./libtool --tag=CC   --mode=link cccl  /W3 /Zc:wchar_t- /O2
> /Ob1 /Os /GL /GF /FD /Gy /MD -version-info 0:0:0 /LTCG -o
> -rpath
> /home/dbyron/src/tuneup/tuneup_juce/trunk/install/lib/Release
> pcreposix.lo /LTCG 
> cygpath: can't convert empty path
> libtool: link: warning: undefined symbols not allowed in
> i686-pc-cygwin shared libraries
> lib -OUT:.libs/libpcreposix.lib  pcreposix.obj
> Microsoft (R) Library Manager Version 8.00.50727.762
> Copyright (C) Microsoft Corporation.  All rights reserved.
> pcreposix.obj : MSIL .netmodule or module compiled with /GL found;
> restarting link with /LTCG; add /LTCG to the link command line to
>  improve linker performance
> Microsoft (R) Library Manager Version 8.00.50727.762
> Copyright (C) Microsoft Corporation.  All rights reserved.
> creating
> (cd .libs && rm -f && ln -s ../
> I tried as hard as I know how to get /LTCG on the lib command line, by
> invoking configure with LIB=/LTCG and LDFLAGS=/LTCG.  Here's the
> complete configure invocation:
>   $ ../configure CC=cccl CXX=cccl CPPFLAGS=-DPCRE_STATIC -DNDEBUG
> CFLAGS=/W3 /Zc:wchar_t- /O2 /Ob1 /Os /GL /GF /FD /Gy /MD CXXFLAGS=/W3
> /EHsc /Zc:wchar_t- /O2 /Ob1 /Os /GL /GF /FD /Gy /MD LDFLAGS=/LTCG
> --enable-shared=no --enable-newline-is-anycrlf --enable-bsr-anycrlf
> --enable-unicode-properties
> --prefix=/home/dbyron/src/tuneup/tuneup_juce/trunk/install
> --libdir=/home/dbyron/src/tuneup/tuneup_juce/trunk/install/lib/Release
> The configure script was generated with autoconf 2.61.
> was generated with automake 1.10.  Looking into, I see:
> PACKAGE=libtool
> VERSION=1.5.23b
> TIMESTAMP=" (1.1220.2.437 2007/02/17 09:08:45)"
> Is this enough version info to see what tools I'm using?  Any
> suggestions about how to get an option to the librarian?
> Thanks much.
> -DB
> PS I'm also curious about the:
> cygpath: can't convert empty path
> warning that comes from this line in the generated libtool script:
> fix_srcfile_path="`cygpath -w "$srcfile"`"
> I guess this gets called with an empty $srcfile but I'm not sure why.
> _______________________________________________

19. - 21. Februar 2008
Salomon Automation auf der LogiMAT 2008, Neue Messe Stuttgart, Deutschland
Halle 6, Stand 527

23. - 27. Februar 2008
MoveRetail auf der EuroShop 2008 in Dusseldorf, Deutschland
Halle 6, Stand C50

Salomon Automation GmbH - Friesachstrasse 15 - A-8114 Friesach bei Graz
Sitz der Gesellschaft: Friesach bei Graz
UID-NR:ATU28654300 - Firmenbuchnummer: 49324 K
Firmenbuchgericht: Landesgericht fur Zivilrechtssachen Graz

Attachment: pcre-patches.tar.gz
Description: pcre-patches.tar.gz

reply via email to

[Prev in Thread] Current Thread [Next in Thread]