lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Add scheme engraver for StaffTab notation


From: Werner LEMBERG
Subject: Re: [PATCH] Add scheme engraver for StaffTab notation
Date: Tue, 24 Feb 2015 23:05:34 +0100 (CET)

>> that simplifies
>>
>>   \makeDefaultStringTuning #'guitar-tuning \stringTuning <e, a, d g b e'>
>>
>> to the much more readable
>>
>>   \T "guitar" <e, a, d g b e'>
>
> You can write
>
> \makeDefaultStringTuning guitar-tuning \stringTuning <e, a, d g b e'>
>
> already.  \T is not "more readable" but merely shorter.

Well, `merely shorter' in this is case *is* `more readable' to me.

> It would be possible to redefine \makeDefaultStringTuning to
> _optionally_ allow
>
> \makeDefaultStringTuning guitar-tuning <e, a, d g b e'>
>
> as well.

Ah, this would help a bit.

> I don't believe in "increasing readability" by renaming symbols into
> stuff that is not the same in definition and usage.

OK.  What about this?

  #(for-each
    (lambda (elem)
      (let* ((sym (car elem))
             (chord (cdr elem)))
        (ly:parser-include-string
           parser
           (string-append "\\makeDefaultStringTuning " sym "-tuning"
                          " \\stringTuning <" chord ">"))))

      '(("guitar" . "e, a, d b g e'")
        ("guitar-seven-string" . "b,, e, a, d b g e'")
        ("guitar-drop-d" . "d, a, d g b e'")
        ("guitar-drop-c-tuning" . "c, g, c f a d'")
         ...
        )
   )


    Werner



reply via email to

[Prev in Thread] Current Thread [Next in Thread]