[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] GPS Not working with Paparazzi with AR Drone 2.0 Help

From: Nathan Speidel
Subject: [Paparazzi-devel] GPS Not working with Paparazzi with AR Drone 2.0 Help
Date: Wed, 24 Feb 2016 22:15:04 -0800

Hello again all!!

My partner and I are still having trouble getting the GPS to work with the Paparazzi software.   I thought I would try to post a summary of what we've done and hopefully someone can help.  

We are using the AR Parrot Drone 2.0.

We have tried two GPS units:   

A UBlox GPS which can be seen here:

and we have also tried the AR Flight recorder:

We had to wire the UBlox GPS to a SparkFun USB to Serial chip, which can bse seen here:

I have attached pictures of the back of the chip.   We soldered on some breakaway headers to the USB to serial chip, because we weren't sure what to wire the GPS to.   As you can see in the picture the GPS had 6 wires.   I think we figured out that the orange and white wires were for the compass, so we didn't wire those to anything.   We wired the black, green, red and yellow wires in various configurations including 

2. TXD, RXD, 3.3v, GND
3. TX-O, RX-I, 3v3v, GND


When we have the UBlox gps set up and we plug in the drone, the GPS lights up.   We can then run Paparazzi Center on my Linux machine and connect to the Drone wifi.   We can upload the software to the drone, but then when we execute the "Flight UDP/WiFi" session, the GPS doesn't appear to be working.    We can select the GPS tab and it just shows zeros. 

This same problem happens if we start the session with the AR Drone Flight Recorder plugged in. 

Does anyone have any thoughts about what to do next? 

What would be the next thing to do for troubleshooting? 

Inline image 2Inline image 3Inline image 1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]