qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v7 02/12] multifd: Create page_count fields into both MultiFD


From: Leonardo Brás
Subject: Re: [PATCH v7 02/12] multifd: Create page_count fields into both MultiFD{Recv,Send}Params
Date: Thu, 11 Aug 2022 05:10:59 -0300
User-agent: Evolution 3.44.3

On Tue, 2022-08-02 at 08:38 +0200, Juan Quintela wrote:
> We were recalculating it left and right.  We plan to change that
> values on next patches.
> 
> Signed-off-by: Juan Quintela <quintela@redhat.com>
> ---
>  migration/multifd.h | 4 ++++
>  migration/multifd.c | 7 ++++---
>  2 files changed, 8 insertions(+), 3 deletions(-)
> 
> diff --git a/migration/multifd.h b/migration/multifd.h
> index 86fb9982b3..e2802a9ce2 100644
> --- a/migration/multifd.h
> +++ b/migration/multifd.h
> @@ -82,6 +82,8 @@ typedef struct {
>      uint32_t packet_len;
>      /* guest page size */
>      uint32_t page_size;
> +    /* number of pages in a full packet */
> +    uint32_t page_count;
>      /* multifd flags for sending ram */
>      int write_flags;
>  
> @@ -147,6 +149,8 @@ typedef struct {
>      uint32_t packet_len;
>      /* guest page size */
>      uint32_t page_size;
> +    /* number of pages in a full packet */
> +    uint32_t page_count;
>  
>      /* syncs main thread and channels */
>      QemuSemaphore sem_sync;
> diff --git a/migration/multifd.c b/migration/multifd.c
> index d2070c9cee..aa3808a6f4 100644
> --- a/migration/multifd.c
> +++ b/migration/multifd.c
> @@ -279,7 +279,6 @@ static void multifd_send_fill_packet(MultiFDSendParams *p)
>  static int multifd_recv_unfill_packet(MultiFDRecvParams *p, Error **errp)
>  {
>      MultiFDPacket_t *packet = p->packet;
> -    uint32_t page_count = MULTIFD_PACKET_SIZE / p->page_size;
>      RAMBlock *block;
>      int i;
>  
> @@ -306,10 +305,10 @@ static int multifd_recv_unfill_packet(MultiFDRecvParams 
> *p, Error **errp)
>       * If we received a packet that is 100 times bigger than expected
>       * just stop migration.  It is a magic number.
>       */
> -    if (packet->pages_alloc > page_count) {
> +    if (packet->pages_alloc > p->page_count) {
>          error_setg(errp, "multifd: received packet "
>                     "with size %u and expected a size of %u",
> -                   packet->pages_alloc, page_count) ;
> +                   packet->pages_alloc, p->page_count) ;
>          return -1;
>      }
>  
> @@ -936,6 +935,7 @@ int multifd_save_setup(Error **errp)
>          p->iov = g_new0(struct iovec, page_count + 1);
>          p->normal = g_new0(ram_addr_t, page_count);
>          p->page_size = qemu_target_page_size();
> +        p->page_count = page_count;
>  
>          if (migrate_use_zero_copy_send()) {
>              p->write_flags = QIO_CHANNEL_WRITE_FLAG_ZERO_COPY;
> @@ -1183,6 +1183,7 @@ int multifd_load_setup(Error **errp)
>          p->name = g_strdup_printf("multifdrecv_%d", i);
>          p->iov = g_new0(struct iovec, page_count);
>          p->normal = g_new0(ram_addr_t, page_count);
> +        p->page_count = page_count;
>          p->page_size = qemu_target_page_size();
>      }
>  

Same comment as Patch [1/12] here.

FWIW:
Reviewed-by: Leonardo Bras <leobras@redhat.com>

Best regards, 
Leo




reply via email to

[Prev in Thread] Current Thread [Next in Thread]