[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[RP] Startup and groups problems

From: Daniel Webb
Subject: [RP] Startup and groups problems
Date: Fri, 9 Jun 2006 20:59:55 -0600
User-agent: Mutt/1.5.11

I'm having a lot of problems getting ratpoison to do what I want.  I just
started using ratpoison today, but I read everything I could find and didn't
see answers.  What I want is:

Have a specified set of named groups and windows created at startup with all
my stuff, sort of like KDE remembers any KDE-aware windows that were open when
you shut down and then starts them up again.  This doesn't have to be
automatic, it's ok if that just means setting up my .ratpoisonrc with what I
want.  I can't get that to work though.

Here's what I currently try (.ratpoisonrc):
exec /home/webb/scripts/ratpoison/rpws init 6 -k

# Use the name of the program rather than the title in the window list
defwinname name

# bind M-! to store the current frame layout in slot #1
bind M-exclam exec ratpoison -c "setenv fs1 `ratpoison -c 'fdump'`"

##aliasing keys within ratpoison
###make semicolon invoke ratpoison command, and colon shell command.
bind semicolon colon
bind colon exec

###Getting a root terminal. There is no binding for "c", since that
###is a default binding, to a terminal.
bind C exec ssh -X address@hidden xterm
###Runs a shell script which creates an alt-tab menu analog
bind w exec ~/scripts/ratpoison/windows
# Ratpoison windows:
# Group 1 : Firefox
#     1+ Firefox
# Group 2 : Email
#     1 mutt 
# Group 3 : Admin
#     1 root screen
#     2 webb screen
#     3 drivebymail screen (root)
#     4 drivebymail pgadmin3
# Group 4 : Projects
# Group 5 : School
#     1 gvim monstrosity
#     2 mycode shell
#     3 park shell
#     4 studies shell
#     5 temp shell

# --------------
# I don't like screens with number 0, so I start an xterm in the 0
# slot then kill it when everything is loaded.
# --------------
#exec xterm
#exec firefox &
exec /home/webb/scripts/ratpoison/rpws 2 
exec xterm 
exec /home/webb/scripts/mail/mutt_start
echo test1
title Mail
select 0
exec /home/webb/scripts/ratpoison/rpws 3 
exec xterm 
exec screen 
title root admin screen
exec screen 
title webb admin screen
select 0

In my VNC logs I get:

Must be connected to a terminal.
Must be connected to a terminal.
unknown group 'wspl2'
unknown group 'wspl3'

I also changed the rpws script to map C-1 through C-9 to the change group
alias, but that doesn't seem to have worked, since I get "readkey: unbound key
'C-1'" etc.  It worked fine when I was trying with the beta4 release in debian
unstable, but that was using a different method apparently.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]