[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

distclean not removing a directory / distcleancheck

From: David Byron
Subject: distclean not removing a directory / distcleancheck
Date: Thu, 27 Jul 2006 11:27:33 -0700

I've got a couple of distclean-related questions.  I'm using automake 1.9.6.

My setup is like this:


where both foo and foo/testsuite contain  The in
foo contains

DIST_SUBDIRS = testsuite

foo also contains which says among other things:


So, if I create a build directory

$ mkdir build
$ cd build
$ ../configure

I end up with a directory named build/testsuite that contains Makefile

I'd like make distclean to clean up this testsuite directory, but I'm not
sure how to do it.

When I execute

$ make distclean

make descends into the testsuite directory and cleans things up, but the
directory itself is left behind.  I've tried adding


to the top level, but then I see this in the output:

test -z "testsuite" || rm -f testsuite
rm: cannot remove `testsuite': Is a directory
make[1]: [distclean-generic] Error 1 (ignored)

Any idea how to remove the testsuite directory as part of distclean?  My
reflex is that automake should clean it as a result of me including it in
DIST_SUBDIRS, following the "if configure built it, then distclean should
delete it" note in the docs.

My second question is about the distcleancheck recipe.

If, immediately after configuring, I run make distcleancheck, it passes.
Given what's going on with my leftover testsuite directory, I'm not sure
that's right, but my question is different.

But, if I run make dist so that I have a dist tarball in my build directory,
make distcleancheck fails.  Is seems like it shouldn't.

Thanks much for your help. 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]