bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: echo "enhancement" leads to confused legacy script tools...


From: Chet Ramey
Subject: Re: echo "enhancement" leads to confused legacy script tools...
Date: Mon, 20 Mar 2006 14:15:42 -0500

> Paul Eggert <address@hidden> writes:
> 
> > Hence Bash can interpret \123 as an octal escape as well, if it so
> > chooses, and still conform to POSIX+XSI.
> 
> But note that bash interprets -n as an option, which is not compliant with
> XSI.

Bash claims XSI conformance when in posix mode with the xpg_echo shell
option enabled, and in this case is conformant.

Chet

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
( ``Discere est Dolere'' -- chet )
                                                Live Strong.
Chet Ramey, ITS, CWRU    address@hidden    http://tiswww.tis.case.edu/~chet/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]