[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: More on 1.11.2 corruption problem

From: Mike Quinn
Subject: Re: More on 1.11.2 corruption problem
Date: Thu, 19 Sep 2002 08:52:43 -0700

I built it myself (didn't know where to get an executable).

Also built 1.11 myself.

make check

worked fine.

What I can try and do is create a 1 or 2 file database that
duplicates the problem, and send it to whoever needs it.

I'll have to do that later today or tomorrow - I'm still
working on restoring the backup.

I will also double-check the "local", but I do all my work
on the machine with the cvs database, so I'm 99.9% sure
when I tried it the second time, it was local. I agree NFS
would be the most likely culprit, although corrupting over
1/2 the files is hard to believe.

I suppose it's possible that the files have some subtler corruption
that adding another tag pushed over the edge..

I'm running "check" now on several databases, so I'll report what the
results are when it's done - it's taking quite a long time to run!
-Mike Quinn

*********** REPLY SEPARATOR  ***********

On 9/19/2002 at 11:36 AM lawrence.jones@eds.com wrote:

>Mike Quinn writes:
>> I ran my own script and checked out 100 different branches and it worked
>fine before
>> adding the branch, and breaks big-time afterwards.
>It certainly sounds like your CVS 1.11.2 is broken -- did you build it
>yourself or did you get an executable from somewhere?  Obviously, such a
>serious error would have been reported long ago if it affected CVS in
>general.  Are you sure you can cause the corruption with a local
>repository?  Most corruption is caused by NFS bugs.  Have you run the
>sanity checks (make check) to validate your CVS executable?
>-Larry Jones
>I stand FIRM in my belief of what's right!  I REFUSE to
>compromise my principles! -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]