[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: Recent changed in NSMenu and friends
From: |
Serg Stoyan |
Subject: |
Re: Recent changed in NSMenu and friends |
Date: |
Sun, 30 Mar 2003 22:21:42 +0300 |
Hello Willem,
> Some changes are done to the NSMenu and friends I am not really
> sure about. Especially the changes relating to when
> to call update/sizeToFit.
>
> As it is now it does not work correctly, transient windows
> have close buttons etcetera. In my opinion the methods
Give me example, please, of such miswork. I have latest CVS and
everything works correct for me.
> "update" and "sizeToFit" have two distinct purposes:
>
> * update.
> Update should be called when the "content" is changed
> in order to give the gui component a change of being
> aware of the change. This method should NOT redraw
> the component.
>
> * sizeToFit.
> Is a more lowlevel call that will update sizes of itself,
> subcomponents, enclosing components or a subset thereof
> to accomodate the receiver component.
>
>
> So I would say that it is ok to call "sizeToFit" from
> "update" but not they other way around, as it is done
> in the NSMenu stuff right now.
Agree with above.
> If nobody complains I will apply the following patch
> shortly.
>
>
> 2003-03-30 Willem Rein Oudshoorn <woudshoo@xs4all.nl>
>
> * Source/NSMenu.m: replaced ivar _changed by _needsSizing
> ([NSMenu -sizeToFit]): call [_view sizeToFit] instead of update
> ([NSMenu -displayTransient]): added call [_view update]
> ([NSMenu -closeTransient]): added [_view update]
Why we should update closing transient? What we should update?
Everything else seems OK for me, but this is mostly style corrections
than bugfixes.
--
Serg Stoyan