[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libtool 2.2] testsuite: 18 19 64 failed [Solaris 7 SPARC]

From: Ralf Wildenhues
Subject: Re: [libtool 2.2] testsuite: 18 19 64 failed [Solaris 7 SPARC]
Date: Fri, 7 Mar 2008 20:41:56 +0100
User-agent: Mutt/1.5.17+20080114 (2008-01-14)

* Bob Friesenhahn wrote on Fri, Mar 07, 2008 at 08:17:03PM CET:
> On Fri, 7 Mar 2008, Ralf Wildenhues wrote:
>>> Because we generally use the same archive_cmds for F77, FC as for CXX,
>> No we don't.  archive_cmds _is_ tagged.  In a casual test, it worked
>> just fine for me to mix gcc and g++ with Solaris 10 f77 and f90.
> You may recall that mixing tools was not working for me under Solaris 10 
> so I have fortran variables (F77 & FC) set to 'no' in config.site so that 
> they won't be used in the libtool tests.  At the time I thought that 
> perhaps this was due to a lacking libtool feature rather than a 'bug'.

Well, it works with Libtool 2.2 on blade, I just tried.  :-)

Not completely, mind you, but at least there are no test failures with
  configure -C CC=gcc CXX=g++ F77=f77 FC=f90

After f{77,c}demo-{conf,shared}.test, the build fails due to
unreferenced symbols, roughly like this:

libtool: link: f90 -G -z defs -h libmix.so.0 -o .libs/libmix.so.0.0.0  
.libs/foof.o .libs/foof2.o .libs/fooc.o
Undefined                       first referenced
 symbol                             in file
puts                                .libs/fooc.o
__f90_slw_ch                        .libs/foof.o
__f90_sslw                          .libs/foof.o
__f90_eslw                          .libs/foof.o

which can be worked around by not using -no-undefined, or probably fixed
by fixing the extraction of all the Fortran support libraries from the
verbose link output.  Nothing terribly bad, and the above issues only
cause SKIPs in the testsuite.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]