[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond 2.2.0: cannot produce postscript

From: Mats Bengtsson
Subject: Re: Lilypond 2.2.0: cannot produce postscript
Date: Wed, 28 Apr 2004 11:25:21 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

You don't, by chance, have the environment variable $LILYPONDPREFIX
set? Or the variable $TEXPSHEADERS?

To check why it doesn't work from within the lilypond script, run
lilypond with the additional flag --debug and check what it says
on the line starting with

For the case when you call dvips directly from the command line,
I hope you have read what INSTALL.txt has to say about the files


Derrick Everett wrote:

I built version 2.2.0 a few days ago. I cannot find any way around a problem with dvips.

If for example I run lilypond on a simple test.ly program, lilypond produces a .dvi file, then (with the default options) lilypond invokes dvips, which fails. Running dvips standalone I get the same error:

$ dvips  -ta4 -Ppdf -G0 -u +lilypond.map -otest.ps test.dvi
This is dvips(k) 5.92b Copyright 2002 Radical Eye Software (www.radicaleye.com)
' TeX output 2004.04.28:1029' -> test.ps
dvips: ! Couldn't find header file music-drawing-routines.ps

The file that dvips cannot find is installed in the following directories:

I have tried copying this file to other directories but dvips still complains that it cannot find the file.

This problem also prevents me from running 'make web'.

        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Phone: (+46) 8 790 8463                         
        Fax:   (+46) 8 790 7260
        Email: address@hidden
        WWW: http://www.s3.kth.se/~mabe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]