[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lilypond-book DVI to PDF problems

From: Jonathan Kulp
Subject: Re: lilypond-book DVI to PDF problems
Date: Wed, 03 Dec 2008 19:03:58 -0600
User-agent: Thunderbird (X11/20081125)

Jonathan Kulp wrote:
There seems to be a bug in 2.11.65 when it comes to converting the DVI output of lilypond-book (LaTeX source files) to pdf. I suspect that something is wrong in the creation of the dvi file, because a regular LaTeX file (i.e. a LaTeX file without any lilypond stuff in it) runs successfully and converts from dvi to pdf perfectly.

When I couldn't make it work in 2.11.65 I reinstalled 2.11.63, the last version I ran the files successfully with, and ran the files again successfully. I reinstalled 2.11.65 and it failed again. I then installed 2.11.64-1 and ran the files successfully again. Apparently the problem comes between 2.11.64 and 2.11.65.

Would someone mind trying lilypond-book with a LaTeX file and converting to pdf to confirm this?

Here are the commands I performed:

lilypond-book --output=out --pdf filename.lytex

cd out

latex filename.tex

dvipdf filename.dvi

My computer runs Ubuntu 8.04 on x86 processor.

My terminal output is attached from a successful run in 2.11.64 ("success.txt") and from the failed run in 2.11.65 ("errors.txt")--see the last 10-15 lines for the error messages. Although the successful run shows some error messages at the end, everything compiled properly. You can see that the "errors.txt" has very different messages at the end. Oh yes, I've also attached a tar of the small test document I used to generate the terminal output.



Quick follow-up to this. The installation of 2.11.65 that failed was one that I built from source pulled from git today. Just to try one more variable, I installed the pre-compiled binary of 2.11.65 and (of course) it ran the files successfully. I suppose something didn't go right when I compiled today. Funny because the installation I compiled worked fine on regular lilypond files but it didn't work with lilypond-book.

So now I don't really know whether there's a problem or not. :( If anyone feels like investigating this I'd be very curious to see how it goes.


Jonathan Kulp

reply via email to

[Prev in Thread] Current Thread [Next in Thread]