[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Strange FAT32 resize problem

From: Dimitri Butvinik
Subject: RE: Strange FAT32 resize problem
Date: Sat, 8 Mar 2003 09:25:57 -0600

Cluster size of my original 3Gb partition is 16k. I did it with PQMagic
prior to saving master image to file. I thought that final resizing on
client's HD will be faster and simpler if original part already at

As a test I have tried to resize 3Gb part with 4k cluster to 10Gb and
19Gb via parted. Same thing - 10Gb boots, 19Gb doesn't.

This is WinXP Pro so SYS doesn't apply. I did try FIXBOOT from WinXP
recovery console and it fixes it right away. Note: FIXMBR doesn't fix
it, FIXBOOT does. Points out that issue is in boot sector not MBR.

Seems like a bug in resizing formula used to construct boot sector
parameters. I'm trying to learn boot sector structure and also compare
working and non working boot sector. So far I didn't find anything
terribly wrong.


-----Original Message-----
From: Andrew Clausen [mailto:address@hidden 
Sent: Friday, March 07, 2003 3:53 PM
To: Dimitri Butvinik
Cc: address@hidden
Subject: Re: Strange FAT32 resize problem

On Thu, Mar 06, 2003 at 09:44:18PM -0600, Dimitri Butvinik wrote:
> 3. If I do the same thing on the same HD only resize to 10Gb or less 
> it will boot fine. So far I tried resizing my master 3Gb part to 
> 6,9,10,15,19,38 Gb. It will stop booting at sizes 15 and bigger.
> I haven't tried more granular between 10 and 15 so I can't tell exact
> breaking point.

Very odd.

Perhaps it's a cluster size issue?

Can you make the machine bootable again by using the "SYS" command?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]