[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: reiser and stuff...

From: B.Hakvoort
Subject: Re: reiser and stuff...
Date: Thu, 21 Oct 2004 14:53:19 +0200

On Wed, 2004-10-20 at 15:05 +0200, B.Hakvoort wrote:
> Absolutely no offence intended, i've run some tests with Yury's
> progsreiserfs and afaics it works perfectly, but i just hate the
> confusion this situation causes (not to mention all this stupid
> bugreports i'm gonna get about this stuff =)  )

Hmmz, i'm afraid i have to take this back. After some more intensive
testing i ran into the following problem:

After copying some data to and from a newly created partition i scanned
the partition with reiserfsck (from the official package) and it came up
with the following error: 
 Zero bit found in on-disk bitmap after the last valid bit.
Checking internal tree../ 10 (of  12)bad_internal: vpf-10330: block
1858939, item 6: The internal item points to the not legal block
 the problem in the internal node occured (1858939), whole subtree is
Comparing bitmaps..vpf-10640: The on-disk and the correct bitmaps
Bad nodes were found, Semantic pass skipped
1 found corruptions can be fixed only when running with --rebuild-tree

This error prevented me also from resizing the partition, which will
quit with: 
Error: Invalid node detected (1867776). Unknown type.

I was able to rebuild the tree with reiserfsck /dev/hdd1 --rebuild-tree
and the errors where gone.. But when i tried to resize the partition
again i lost it completely!

Also, when i create a new reiserfs filesystem and scan it immediately
after creation i get the following error:
2 found corruptions can be fixed when running with --fix-fixable

All in all very freaky :-(
Is this fixed in progsreiserfs- ? (where can i download this?)
or is this 'normal' behaviour?
Afaict it's simply not safe to give this to the endusers..



www.titanium-it.nl --- Open Minded Open Source
www.real-life.nl <-----Another Source

reply via email to

[Prev in Thread] Current Thread [Next in Thread]