gnugo-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gnugo-devel] more owl revisions


From: Paul Pogonyshev
Subject: [gnugo-devel] more owl revisions
Date: Wed, 7 May 2003 00:56:59 -0400
User-agent: KMail/1.5.9

this patch retires "If eyespace includes an owl inessential string, we must
assume that the pessimistic min is 0" policy. it must have no regression
breakage (didn't have a while ago) and give a slight decrease in owl nodes.

Paul


Index: engine/owl.c
===================================================================
RCS file: /cvsroot/gnugo/gnugo/engine/owl.c,v
retrieving revision 1.156
diff -u -p -r1.156 owl.c
--- engine/owl.c        4 May 2003 11:39:48 -0000       1.156
+++ engine/owl.c        6 May 2003 21:47:33 -0000
@@ -2604,12 +2604,10 @@ owl_determine_life(struct local_owl_data
          || (mw[pos] < 3 * mz[pos] && mz[pos] > 5))
        pessimistic_min = 0;
 
+      /* It appears that this policy is needed no longer. */
+#if 0
       /* If this eyespace includes an owl inessential string, we must assume
-       * assume that the pessimistic min is 0.
-       *
-       * See owl1:304 for an example where this policy is important.
-       * FIXME: However, a better approach would be to improve inessential
-       *       strings detection (S13 in owl1:304 must count as essential).
+       * that the pessimistic min is 0.
        */
       if (pessimistic_min > 0) {
        for (pos2 = BOARDMIN; pos2 < BOARDMAX; pos2++) {
@@ -2621,6 +2619,7 @@ owl_determine_life(struct local_owl_data
          }
        }
       }
+#endif
 
       eyes_attack_points[num_eyes] = NO_MOVE;
       eyevalue_list[num_eyes] = eyevalue;
@@ -3758,10 +3757,10 @@ owl_reasons(int color)
         * dies because the victim only formed a nakade shape.
         *
         * FIXME: This code overlaps heavily with some code in
-          * examine_move_safety() in move_reasons.c. The caching
-          * scheme should minimize the performance hit, but of course
-          * it's unfortunate to have the code duplication.
-          */
+        *        examine_move_safety() in move_reasons.c. The caching
+        *        scheme should minimize the performance hit, but of course
+        *        it's unfortunate to have the code duplication.
+        */
        int move = DRAGON2(pos).owl_attack_point;
        
        /* No worries if we catch something big. */




reply via email to

[Prev in Thread] Current Thread [Next in Thread]