[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guile-PG 0.91 - what am I doing wrong?

From: Chris Hall
Subject: Re: Guile-PG 0.91 - what am I doing wrong?
Date: Fri, 04 Jun 2004 09:40:50 -1000
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.2 (gnu/linux)

Greg Troxel <address@hidden> writes:
> I just tried 0.16 again, and had to add -R/usr/pkg/lib to
> config.status's pq lib line to get rpath in the
> installed by guile-pg.  I also has to add (current-module) to the eval

Thank you, thank you, thank you!

I grabbed a copy of 0.16, and your '-rpath' hint seems to do the trick.
However, what I did was eyeball the Makefile after running configure,
and put (I hoped) appropriate -rpaths wherever (it seemed) appropriate.

I haven't bothered with the tests just yet - so I haven't tried
'(current-module)' yet - but I plan to, out of curiosity, if nothing
else. ;-) (Seriously, I do need to run the tests before I can even
consider using this in production.)

For now, though, I can at long, long last connect to and query my
postgres server from Guile1.6.4. - I've tried it.  Woohoooo! :-D

Too, I had to clean up the broken 0.19 install by hand - I had moved the
mis-placed directories, so 'make uninstall' didn't work properly in the
0.19 build.  That slowed me down for a while, because the old stuff,
being earlier in the default %load-path, kept loading and baffling
me. ;-}

Thanks again, (and whew!),

We hang the petty thieves and appoint the great ones to public office.
-- Aesop (620 BC - 560 BC)

Attachment: pgpciAX_d6Qu7.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]