[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Guile-PG 0.91 - what am I doing wrong?

From: Chris Hall
Subject: Guile-PG 0.91 - what am I doing wrong?
Date: Thu, 03 Jun 2004 03:06:09 -1000
User-agent: Gnus/5.1006 (Gnus v5.10.6) Emacs/21.2 (gnu/linux)

I've downloaded built and installed Guile-PG 0.19, but I can't seem to
get it working.

Debian Woody, kernel 2.4.18bf,  GCC 3.0.4, GNU make 3.79.1.

Guile 1.6.4 obtained from Savannah and built using GCC 3.0.4.  Guile
installed into /usr/local.

Postgres 7.3.4 obtained from and built 3 days ago.

Configured guile-pg with ./configure --with-pg=/usr/local/pgsql.

The build went OK, and the install _seemed_ to - turns out (after a
couple of hours of reading manuals, poking around in the system, etc.)
that 'make install' put the libs in '/site' *not*
/usr/local/lib/guile/site, and the scripts in /database *not* in

OK, fine, let's move them to where they should have been, and update my
GUILE_LOAD_PATH to point to /usr/local/share/guile/site, my
"/usr/local/pgsql/lib:/usr/local/lib/guile/site".  (I also tried with
"/usr/local/lib/guile/site/database" with the same dismal results).

(use-modules (database postgres)) complains; postgres.scm barfs with 'no
code for (database postgres-sup)'.

Sure enough, no postgres-sup.scm anywhere on the system - not even in
the tarball - though there *are* the postgres-sup* libs in
/usr/local/lib/guile/site/database.  I guess this is where they should
be, but at this point, I have absolutely no confidence in that. :-}

Also, I spent quite some time in the guile reference info - I'm guessing
that postgres-sup.scm, if it exists somewhere, is where 'load-extension'
gets called?

I'm new to guile, but isn't 'load-extension' *required* to load a
dynamic library?  I did a grep, and no load-extension was found anywhere
in database/.

So, what obvious, stupid mistake have I made, or what glaringly obvious
thing am I overlooking?  Has anybody gotten this working?

I had tried guile-pg-0.17 (or was it 0.18?) a few days ago, and it
wouldn't compile, using the exact same setup.

FWIW, I recently built clisp 2.33 against the same Postgres build, and
the clisp postgres support worked flawlessly.  The default Debian
guile-pg (for guile version 1.4) worked fine too, but I wanted to
upgrade to guile1.6, and the Debian testing package would require me to
upgrade my glibc - a bit much for me to risk this point, since I am
getting ready to move and I can't afford to have my computer borked.

Should I go back to guile1.4?  I'm kinda busy and can't really afford to
spend a lot more time on this, but if I am almost there I'd hate to
waste the time I've already spent, though it has been educational.

Thanks for any suggestions,

P.S.  On Debian, guile1.4-pg is separate executable, but for 1.6 has
anyone considered having 'make' generate a shell script with the
appropriate path statments already in the environment?

P.P.S I've also tried to build guile-pgsql, but it complains about not
finding 'c2x' - what on earth is *that* and where do I get it?  My
guile1.6.4 has nothing of the sort, and it is not mentioned in the
reference, but if it helps me get connected to postgres, I'll use it.

I just want to get at postgres from guile, I'm not too fussy about what
tool I use - is there one *known* to work with 1.6.4 that I don't have
to spend two days mucking about with in order to get working?

If you speak the truth, have a foot in the stirrup.
-- Turkish proverb

Attachment: pgpmkSN6SYwTd.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]