[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

emacs 21.2 compile problems on Solaris 8

From: Carl B. Constantine
Subject: emacs 21.2 compile problems on Solaris 8
Date: Tue, 29 Oct 2002 10:47:26 -0800
User-agent: Mutt/1.4i

I'm trying to compile Emacs 21.1 for Solaris 8, both Intel versions and
Sparc versions.

On the Sparc, I'm using gcc 2.95.3. On the x86, I'm using gcc 3.1.1.

In both cases I get this same error:

gcc -c   -I/public/include -I/usr/dt/include   -g -O2 -DEMACS_BITMAP_FILES 
-DHAVE_CONFIG_H -Demacs -I. -I../src 
-I/sw/pgmstore/admpubsw/emacs/emacs-21.2/lwlib/../src xlwmenu.c
In file included from 
                 from xlwmenu.c:32:
/usr/include/strings.h:25: conflicting types for `memmove'
/usr/include/iso/string_iso.h:62: previous declaration of `memmove'
/usr/include/strings.h:26: parse error before numeric constant
make[2]: *** [xlwmenu.o] Error 1
make[2]: Leaving directory `/sw/pgmstore/admpubsw/emacs/emacs-21.2/lwlib'
make[1]: *** [really-lwlib] Error 2
make[1]: Leaving directory `/sw/pgmstore/admpubsw/emacs/emacs-21.2/src'
make: *** [src] Error 2

(The /public/include is an extra include dir for the image libraries -
tiff, jpeg, png, xpm).

I've tried with and without gnu binutils. I've tried with and without
specifying the image libraries (without, emacs doesn't include them in
the configure because they are in a different location for our needs)
but in every case, I get this same error.

Looking at the typescript (generated by the script command) I don't
recall having this problem with Emacs 21.1 on the sparc machine using
gcc 2.95.3.

Anyone have ideas as to what is causing this and how I can fix it?

Carl B. Constantine         University of Victoria
Programmer Analyst
UNIX System Administrator   Victoria, BC, Canada        ELW A220, 721-8753

reply via email to

[Prev in Thread] Current Thread [Next in Thread]