[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: WebRTC support (jitsi) in Guix-packaged browsers?

From: Chris Marusich
Subject: Re: WebRTC support (jitsi) in Guix-packaged browsers?
Date: Sun, 21 Oct 2018 13:01:25 -0700
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Pierre Neidhardt <address@hidden> writes:

>> IceCat 60.2.0-esr
> What is "esr"?  I have IceCat 60.2.0-gnu, would that make a difference?

"ESR" stands for Extended Support Release.  I'm just using the IceCat
that comes with Guix.  The exact version of Guix and IceCat I'm using on
my x86_64-linux GuixSD system is:

--8<---------------cut here---------------start------------->8---
[0] address@hidden:~
$ guix --version
guix (GNU Guix) 40f856fae80ee8a274067fba0837cccb74d9642d
Copyright (C) 2018 the Guix authors
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
[0] address@hidden:~
$ icecat --version
GNU IceCat 60.2.0
[0] address@hidden:~
$ readlink -f $(which icecat)
[0] address@hidden:~
$ guix describe -f channels
(list (channel
        (name 'guix)
        (url "";)

;; warning: GUIX_PACKAGE_PATH="/home/marusich/custom-guix-packages"
[0] address@hidden:~
--8<---------------cut here---------------end--------------->8---

I tried just now to install only IceCat in a fresh profile and run it
without using any unnecessary environment variables.  Jitsi still seemed
to work (I got to the point where it asked permission to use my
camera/microphone, which I denied).  I did this in bash:

    cd $(mktemp -d)
    guix package -p .guix-profile -i icecat
    eval "$(guix package --search-paths -p $(realpath .guix-profile))"

>> I tried typing in "test" and hit "go", and it asked me for permission
>> to use the microphone and camera.
> This is the expected behaviour.  On my end, I have a grey background and 
> nothing
> else.  No popup.

Have you installed any extensions/plugins in IceCat that might
interfere?  Is there any indication of what went wrong in the dev
console (error HTTP status codes, JavaScript warnings, etc.)?

If you can install normal FireFox on your OS, does it work?  This might
help determine if it's a problem with your installation of IceCat.

>> since I don't really know what that website or jitsi is about,
>> although I see that (at least some parts of jitsi) are free software,
>> which is nice to know.
> It is free software (Apache license) as far as I know.
> You can run your own instance if you like.  Jitsi has been one of the best 
> VoIP
> experience I've had.

Cool!  I've been curious about trying GNU Ring, myself, but I haven't
had time to look into it much.  Nice to know there are other free
software options out there, also.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]