[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: wheeee! installed. no network. now what? :)

From: Luke Kenneth Casson Leighton
Subject: Re: wheeee! installed. no network. now what? :)
Date: Mon, 27 Jan 2003 10:42:21 +0000
User-agent: Mutt/1.4i

On Mon, Jan 27, 2003 at 11:12:08AM +0100, Alfred M. Szmidt wrote:
>     because marcus helped me get hurd installed when i met him in
>     bristol last year and it didn't work.
> Didn't work and didn't get detected are two very different things.  My
> eepro100 card works quite fine with GNU Mach 1.3.  So you still need
> to be more specific.  I ask once again; how did you setup pfinet? 

 i didn't - i didn't know it existed!

 i don't have an eepro100 card _per se_, btw, it's built-in
 into the sony portable (pcg-z600hek).

> Did
> the card get detected?  And finally, did you sacrifice your soul to
> Saint IGNUcius?

>     yes i read the installation guide.  especially the networking
>     section which contains no information, and i mean no information.
>     the section heading is there but the content is blank.
> Sorry, but this is completely false.  From section 7.1 The Network:
>   To configure the network, the pfinet translator must be
>   configured. This is done using the settrans command to attach a
>   translator to a given filesystem node. When programs access the node
>   by, for example sending an RPC, the operating system will
>   transparently start the server to handle the request.

hm.  i used google to search, last month, for some of this
stuff.  if my memory serves correctly, it was on

i definitely definitely came across a blank section on networking.

i promise.

>   # settrans -fgap /servers/socket/2 /hurd/pfinet -i eth0 \
>    -a a.b.c.d -g e.f.g.h -m i.j.k.l
> [...]
> If you think the wording is bad, please send a suggestion on how to
> make it clearer.  You can read more about what options pfinet has by
> supplying --help to pfinet (i.e. /hurd/pfinet --help).
 okay, that i found and tried last night.

 google threw up something on the debian lists.

 the error message i get (from memory) is that permission is
 denied because the socket is already in use.

 so i took a look in /servers/socket and found a symbolic link
 inet already existed (???)

 so i did ifconfig -i eth0 and it said eth0 (-1)


 then i did ps ax | grep pfinet and found that yes, a pfinet
 _did_ exist, so i killed it.

 then i tried the settrans command again and it worked.

 ifconfig -i eth0 however reported the same message.

 then i did ls -altr /servers/socket and it reported that
 pfinet died.

>     next time you respond, please do both myself, and yourself, a
>     favour: please try not to make your response, to someone who is
>     enthusiastic about your project, sound like you want to kick their
>     head in.
> If trying to actually help someone politely sounds like one wants to
> kick them in the head, so be it. 

 i apologise: i'm over-sensitive to these things (given the
 history of how badly the samba team leaders treated me and
 my work), and tend to over-react to even the slightest thing.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]