[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

disklabel and ufs problems

From: Marek Dopiera
Subject: disklabel and ufs problems
Date: Sat, 12 Jul 2008 17:17:01 +0200
User-agent: KMail/1.9.9

I have tried to use ufs under the Hurd, but was unsuccessful. I am new to it 
so it may be my silly error, but I have no idea what it might be.

No matter if I create the ufs filesystem under Hurd or NetBSD and no matter if 
it is FFS1 or FFS2 or which compat I use in /hurd/ufs, 
settrans -a /mnt /hurd/ufs /dev/hd1s succeeds, but strange things happen:
# ls /mnt
# touch /mnt/test
# ls /mnt
? ? test

settrans -g /mnt also succeeds without warnings.

When I mount the partition under NetBSD file test doesn't appear. Under Hurd 
it does. The qeuestion marks are also weird. Below is the effect of 
ls -la /mnt under Hurd:
?--------- ? ?    ?     ?            ? /mnt/?
?--------- ? ?    ?     ?            ? /mnt/?
-rw-r--r-- 1 root root 15 Jul 11 21:25 test

After creating more files, some of them have some unprintable characters 
appended under the Hurd. NetBSD's fsck complains about wrong directory 

I also tried to make use of the disklabel, which I created in NetBSD:
#        size    offset     fstype [fsize bsize cpg/sgs]
 c:   1044162        63     unused      0     0        # (Cyl.      0*-     
 d:   1044225         0     unused      0     0        # (Cyl.      0 -     
 e:   1044162        63     4.2BSD      0     0     0  # (Cyl.      0*-     

This is coherent with the dos partition table and stored in sector 64.
I have created /dev/hd1e with MAKEDEV, showtrans gives /hurd/storeio hd1e, but 
trying to do anything with the device (eg mkfs.ufs) results in "No such 
device or address". hd1s1 works though.

Do you have any idea what might be wrong? I'd be grateful for any clues, 
especially for the first issue. Thanks in advance.


Marek Dopiera,
JID:, GG:219418

reply via email to

[Prev in Thread] Current Thread [Next in Thread]