[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Migrating from sourcesafe to cvs

From: Patrick Decat
Subject: Re: Migrating from sourcesafe to cvs
Date: Wed, 25 Jul 2001 16:09:18 +0200

From: <address@hidden>
> Patrick Decat writes:
> >
> > I tried to share *files* from my 'test' module using this 'modules' file 
> definitions:
> > test test
> > test_share1 test/subdir1 File3
> > test_share2 test/subdir2 File5
> > test_share  -a test_share1 test_share2
> >
> > Then, checking out this 'test_share' module results in the following:
> > > cvs co test_share
> > U test_share1/File3
> > U test_share2/File5
> >
> > The behaviour I try to meet is:
> > > cvs co test_share
> > U test_share/File3
> > U test_share/File5
> Use -d in the module definitions to put the files where you want:
>         test test
>         test_share1 -d test test/subdir1 File3
>         test_share2 -d test test/subdir2 File5
>         test_share  -a test_share1 test_share2
> -Larry Jones

Well, I have tried that but it does not work.

Once the first module 'test_share1' has been checked out to the
'test' directory, the next module 'test_share2' cannot be checked out
into the same 'test' directory as the content of 'test/CVS/Repository'
points to /opt/cvsrepository/test/subdir1.

Here is the error message that this configuration generates:
> cvs co test_share
U test/File3
U test/File4
cvs server: existing repository /opt/cvsrepository/test/subdir1 does not match 
cvs server: ignoring module test_share2


reply via email to

[Prev in Thread] Current Thread [Next in Thread]