[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pserver config worked on Mdk 8.0, fails on RH 7.1...why?

From: David Fuller
Subject: Re: pserver config worked on Mdk 8.0, fails on RH 7.1...why?
Date: Tue, 31 Jul 2001 14:13:12 -0400

Check your server side logs.  You'll probably find some error message in
one of the log files that would help you identify what is

Are the versions of CVS the same on your machine and the new one?

> "Beachey, Kendric" wrote:
> We have just adopted CVS as our source control platform in my
> department.  When I was doing the proof of concept to convince
> everyone it was a good idea, I was (and still am) running CVS on my
> desktop machine, which runs Mandrake 8.0.
> Now that CVS has been blessed, the boss has bought a fancy new machine
> to serve as our real CVS repository, and it runs Red Hat 7.1.  I have
> verified that cvs the client works just fine on the new machine, and I
> successfully used 'cvs init' to start a new repository.  The problems
> are with trying to make the pserver run on the new machine.
> Like my desktop machine, the new one uses xinetd instead of regular
> inetd, which is what is used in the examples in Karl Fogel's excellent
> documentation.  The man pages gave me enough to set it up to run
> properly on Mandrake, but doing the same thing on Red Hat isn't
> working.  Here is an example of what happens when I try to run 'cvs
> login' against the new machine:
> address@hidden beachey]$ cvs -d \
>      :pserver:address@hidden:/cvs login
> (Logging in to address@hidden)
> CVS password:
> cvs [login aborted]: recv() from server Connection
> reset by peer
> address@hidden beachey]$
> It doesn't matter if I type the right password or not.
> The relevant details of the config files:
> * /etc/services already contained tcp and udp lines for port 2401 for
> cvspserver
> * /etc/xinetd.d now contains a file called "cvs" that is identical to
> my working one on the Mandrake machine--it points to
> /usr/sbin/cvspserver
> * /usr/sbin/cvspserver is a shell script that reads /etc/cvs/cvs.conf
> to find the value(s) of CVS_REPOS, then calls 'cvs pserver' using a
> separate '--allow-root' for each item in CVS_REPOS
> * /etc/cvs/cvs.conf just says CVS_REPOS="/cvs"
> * ummm...anything else you'd like to know about, I can provide.  :-)
> Many thanks in advance for any help you can give!
> PS: I just noticed that sometimes when trying to do 'cvs login' from
> the actual cvs machine, I sometimes get the message "cvs [login
> aborted]: received broken pipe signal" instead of the connection reset
> message.
> --
> Kendric Beachey
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]