[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: problem with password authentication

From: Ronald Landheer
Subject: RE: problem with password authentication
Date: Tue, 4 Dec 2001 21:34:30 +0100

OK, now I'm using cvs-1.11.1p, and get this in the /var/log/messages file:
Dec  4 20:30:10 jukebox cvs: login failure (for
Aside from the time being on GMT in stead of CET, this doesn't tell me much
I didn't already know - it tells me login failed.

The password in the passwd file is encrypted by this perl script:
-- BEGIN cvs-cryptout --

srand (time());
my $randletter = "(int (rand (26)) + (int (rand (1) + .5) % 2 ? 65 : 97))";
my $salt = sprintf ("%c%c", eval $randletter, eval $randletter);
my $plaintext = shift;
my $crypttext = crypt ($plaintext, $salt);

print "${crypttext}\n";
--- END cvs-cryptout ---
Could you verify that this is OK?
I see no reason why it shouldn't be, but hey..

Other than that, an empty password field in the passwd file should work out
with no password if I do a login, right?
so I changed the line in the passwd file to
That's all

Darn. it works.

OK - it's the password..
Again: is the perl script OK?

Thanx so far :)

> -----Original Message-----
> From: Larry Jones [mailto:address@hidden
> Sent: dinsdag 4 december 2001 21:22
> To: Ronald Landheer
> Cc: address@hidden
> Subject: Re: problem with password authentication
> Ronald Landheer writes:
> >
> > I upgraded to CVS-1.11-3 a while after sending the post
> > I noticed the error in my xinetd.d/cvspserver file just after I sent the
> > post, and fixed it, but it still doesn't work. I removed the
> other possible
> > repositories - still doesn't work. I added -t to the
> command-line options -
> > doesn't produce any more output.
> > Nothing hows up in /var/log/messages (I'm not sure anything is
> supposed to)
> > and I don't know which other logs are kept by CVS (any?)
> CVS 1.11.1p1 (which you can get from logs authorization
> failures using syslog (under the DAEMON facility for general information
> and, if it exists, AUTHPRIV for specific username and password info).
> If you're sure the repository now matches, it's almost certainly a
> password problem.
> -Larry Jones
> Ha!  Wild zontars couldn't drag that information out of me!  Do
> your worst!
> -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]