[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs branching problem

From: Sasha Case
Subject: Re: cvs branching problem
Date: Mon, 17 Dec 2001 09:25:06 +1000

In response to address@hidden ...

> You're branching individual files, rather than the whole directory. So
> now you have a directory that has some files in the branch, and some
> on the trunk. When you do the "update" in the existing sandbox, you
> greatly confuse CVS. When you do the checkout, you only get the files
> that are actually tagged with the branch tag, and thus the other files
> are "removed".

Actually I started off branching a whole directory, but when that failed I
tried explicitely specifying every file in the directory.

I've since overcome the problem, but still don't know what caused it.

The branchname I was using was CES2002, and then CES2002-DEC01 and similar
on successive attempts to make it work.

cvs status -v on a file that was branched would return:

   Sticky Tag:          CES2 02 - MISSING from RCS file!
   Existing Tags:
        CES2002                         (branch: 1.16.2)

So cvsnt seemed to be stripping the first 0 from the branchname!

When I rebranched with CES2K2 as a branchname all worked:

   Sticky Tag:          CES2K2 (branch: 1.16.4)
   Existing Tags:
        CES2K2                          (branch: 1.16.4)
        CES2002                         (branch: 1.16.2)

I've just reproduced the problem on a test module.  Can anyone else confirm
this bug?

I'm using Concurrent Versions System (CVS) NT (Build 27) (client/server)
and WinCVS v1.2.

Sasha Case
Development Engineer, Clarity EQ Pty Ltd
Tel: +61-2-9905-6277, Fax: +61-2-9905-8066
Public key available at ldap:// (ID: 0xCFADA4B7)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]