[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS over SSH hangs

From: Rene Berber
Subject: Re: CVS over SSH hangs
Date: 9 May 2002 14:53:33 -0700

"vkd" <address@hidden> wrote in message news:<address@hidden>...
> Hi, I am experiencing problems using ssh as a shell for CVS.
> Everything works great except two things
> 1. There is a small hang during connection start up:
> # ssh -v -v address@hidden
> OpenSSH_2.9p2, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
> debug1: Reading configuration data /etc/ssh/ssh_config
> debug1: Applying options for *
> debug1: Seeding random number generator
> debug1: Rhosts Authentication disabled, originating port will not be
> trusted.
> debug1: restore_uid
> debug1: ssh_connect: getuid 0 geteuid 0 anon 1
> ---> small hang here <--- about 7-10 seconds
> debug1: Connecting to zorro [] port 22.
> debug1: temporarily_use_uid: 0/0 (e=0)
> debug1: restore_uid
> Remote box is running Solaris 7 with OpenSSH 3.1p1

This is quite normal since (from the OpenSSL documentation) Solaris
doesn't have a /dev/random, generating keys takes a long time.  It's
even worse with old Sparc hardware: everytime you login using ssh
(which is what CVS is doing) you can see the CPU usage go to 100%.

BTW the documentation that comes with OpenSSL (and also de Sun Web
site) recomends installing a /dev/random from one or two sources.  It
does help a little.

> 2. CVS transfer completes, but the session just hangs there as though there
> is no completion of communication:
> # cvs login
What's this doing here?   You only need to log-in if you're using

> # cvs co project
> ...
> ...
> U project/utils/readme.txt
> U project/utils/room.c
> U project/utils/zrea.c     <--- Last file in project.
> ---> indefinate hang here. <---
> What's weird is that if I go into utils area and do cvs update there, it
> works fine. Cvs update results in the same hang when I do it on the whole
> tree. I don't understand why this is going on.
> I tried using pserver over ssh tunnel and that worked fine. Why isn't this
> working?
> Here is what I have defined:
> CVS_RSH=ssh
> address@hidden:/var/cvsroot
> Any ideas?

Try by setting CVSROOT=":ext:address@hidden:/var/cvsroot" and then
just do the "cvs co project".

I don't know why the sample you show hangs, but it has nothing to do
with ssh, it probably is something wrong with cvs.   Better test with
the :ext: protocol and see if it still hangs.

R. Berber
rberber AT

reply via email to

[Prev in Thread] Current Thread [Next in Thread]