[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Newbie Q: "cannot open CVS/Entries for reading"

From: Albin Takami
Subject: RE: Newbie Q: "cannot open CVS/Entries for reading"
Date: Fri, 2 Aug 2002 18:01:35 -0700

 -----Original Message-----
From:   Mike Ayers [mailto:address@hidden
Sent:   Friday, August 02, 2002 4:23 PM
To:     address@hidden
Cc:     address@hidden
Subject:        Re: Newbie Q: "cannot open CVS/Entries for reading"

Albin Takami wrote:

> "...Check out the project tree..."
> Ok, according to the Cederquist (p31): cvs checkout
> /design/project/dig/V9/src
> The system replies: cannot find module '/design/project/dig/V9/src' -
> ignored

        Cederqvist is generally distributed as an HTML file.  Please quote
sections, not pages.  This is preferred practice for all technical
documentation, as it spans revisions better.

Ok, it was section 3.1.1. I used the PDF-format version.

        `cvs checkout /design/project/dig/V9/src` is incorrect syntax.  If
you have built module src in CVSROOT /design/project/dig/V9, then you

$ cvs -d /design/project/dig/V9 checkout src

> Tried importing: cvs import -m "Imported sources"
> digital start
> The system replies: directory /design/project/dig/V9/src is not relative
> within the repository

        That command makes no sense.  What are "digital" and "start"?

This is from the Reservist manual too (sect 3.1.1): cvs import -m "Imported
sources" yoyodyne/rdir yoyo start
I replaced the so called vendor tag "yoyo" with "digital" since yoyo didn't
help me.

> Since she had problem checking out her project tree, she copied her files
> from her directory to /design/project/dig/V9/src and tried to check them
> however it was the same result as I initially got (I don't have any
> checking her files in).

        Ummm - if she copied her files directly into the repository and
started mucking around there, she may have damaged the repository.

To clarify, the repository location is the directory that you set the
CVSROOT variable to, right?

> I tried adding: /design/project/dig/V9/src/cvs add abc.v
> The system replies: [add aborted]: there is no version here; do 'cvs
> checkout' first

        The system agrees with me.

> Lastly, tried to checkout a file as Peggy or myself: cvs
> /design/project/dig/V9/src/cvs checkout abc.v
> System replies: cannot find module 'abc.v'  - ignored

        This is correct behavior.  Modules, not files, get checked out.  The
files are contained in the modules.
Ok, modules in the Verilog language is also file independent, however they
have different meaning than in cvs.
Anyhow, I found out that the modules file is checked in, and the "co"
command was used as an alias for changing directory to a project directory,
so I could not check out the modules file. That is now fixed.

> What else can I do to find the problem?

        Spend a lot more time reading documentation.  Cederqvist, BTW, is a
great reference manual, but a terrible introduction.  Try or, which may be better for
getting started.


Thanks a lot!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]