[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installation problems

From: Alexander Mai
Subject: Installation problems
Date: Mon, 22 Jan 2001 12:13:42 +0100

Last week I have reported about a problem after upgrading to
Now I installed the auto* tools again and it seems things do almost
work now (still get an autoconf error message, but configure
seems to run?!:
autoconf: Undefined macros:
***BUG in Autoconf--please report*** AC_TRY_DLOPEN_SELF

Is there some notice in the docs about the installation order?!
At first glance I can't find installation instrunctions in the docs
(.texi) of all packages, but all feature the useless INSTALL file
and some README comments only.

Ok, got the package to link more or less and ran into the next

libbar depends on libfoo. in turn contains:

# Libraries that this one depends upon.
dependency_libs=' -L/usr/X11R6/lib -lXt' ...

I link libbar against

Now it turns out that in /usr/X11R6/lib an old version of
libfoo exists. And in the following libbar will be linked against
the old /usr/X11R6/lib/ and not the new one.
I tried moving around the compiler/linker flags, but that
didn't solve the problem. Is this is a shortcoming of libtool
or is there a way for me to fix this?

Alexander Mai

reply via email to

[Prev in Thread] Current Thread [Next in Thread]