[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installation problems

From: Alexandre Oliva
Subject: Re: Installation problems
Date: 31 Jan 2001 06:50:41 -0200
User-agent: Gnus/5.0808 (Gnus v5.8.8) XEmacs/21.1 (Crater Lake)

On Jan 22, 2001, Alexander Mai <address@hidden> wrote:

> Now I installed the auto* tools again and it seems things do almost
> work now (still get an autoconf error message, but configure
> seems to run?!:
> autoconf: Undefined macros:
> ***BUG in Autoconf--please report*** AC_TRY_DLOPEN_SELF
> )

Is this CVS autoconf or autoconf 2.13?  I think libtool isn't CVS
autoconf-ready yet.  Akim posted some patches to that effect, but I'm
not sure they've already been integrated.

> Now it turns out that in /usr/X11R6/lib an old version of
> libfoo exists. And in the following libbar will be linked against
> the old /usr/X11R6/lib/ and not the new one.
> I tried moving around the compiler/linker flags, but that
> didn't solve the problem. Is this is a shortcoming of libtool
> or is there a way for me to fix this?

For short, there's no way to solve this problem.  Even if you could
manage to get the linker to find the shared libraries you want to have
linked in, you'd have trouble getting the dynamic linker to load them
from the correct directories.

Having LDFLAGS set up so that the linker searches the build tree first
always helps, but in a case like the one you describe, there's very
little libtool can do by itself to figure out what you really meant.

Alexandre Oliva   Enjoy Guarana', see
Red Hat GCC Developer                  address@hidden,}
CS PhD student at IC-Unicamp        address@hidden,}
Free Software Evangelist    *Please* write to mailing lists, not to me

reply via email to

[Prev in Thread] Current Thread [Next in Thread]