[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Mac OS X isysroot and lib dependencies

From: Heikki Lindholm
Subject: Re: Mac OS X isysroot and lib dependencies
Date: Tue, 10 Jul 2007 20:37:50 +0300
User-agent: Mozilla Thunderbird 1.0.7 (Macintosh/20050923)

Peter O'Gorman kirjoitti:
On Tue, 2007-07-10 at 11:16 +0300, Heikki Lindholm wrote:


I'm trying to build a libtoolized project in a Mac OS X SDK using the appropriate -isysroot/-syslibroot flags, but libtool seems to fail when there's a library installed in the SDK, say /home/MySDK/usr/local/lib, with dependencies in the .la file, such as dependency_libs='/usr/local/lib/',
which only exist in the SDK. The error I get from libtool is:

I don't remember if I fixed this yet. Are you creating your own SDKs?
Apple's SDKs do not contain any .la files.

Anyway, to get it working you will have to edit the generated libtool
script and change lines starting with 'sys_lib_search_path_spec=' so
that the assigned values have the SDK path prepended.

Ok, tried it now. Didn't work. Fails with the exact same error. I changed two lines like

sys_lib_search_path_spec=" /usr/lib/gcc/powerpc-apple-darwin8/4.0.1/ /usr/lib/[...]"

so that all listed paths had /Path/to/my/sdk prepended to them.

-- hl

reply via email to

[Prev in Thread] Current Thread [Next in Thread]