[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: More compile problems with mingw

From: John McCabe-Dansted
Subject: Re: More compile problems with mingw
Date: Thu, 15 Feb 2007 08:13:20 +0900

On 2/15/07, Ben Pfaff <address@hidden> wrote:
"John McCabe-Dansted" <address@hidden> writes:
> Things I haven't tried
>  - running Psppire.exe on a linux/wine machine that supports OpenGL.

Any idea whether these problems show up on actual Windows, or
just under Wine?  I suppose testing under QEMU would work.

I've tested Gtk 2.10 on Windows XP and it works fine. I imagine Gtk
2.6 does too. I could test it tonight.

> FIX/HACK: I worked around error my  compile error by commenting out
> the _g_spawn_command_line_async, which is used to start yelp.

Does glib just not implement this function under Win32?

I believe glib 2.12.7 does, but glib 2.6.6 does not.

> ERROR:  i386-mingw32msvc-gcc: plural.c: No such file or directory
> FIX/HACK: Copy plural.c from a previous pspp build tree.

How did plural.c disappear?

I don't know, but
  cvs up intl/plural.c
did not restore it.

> FIX/HACK: No fix, I just worried about it. If I ignore it, it doesn't
> seem to cause any trouble

These three shouldn't appear in a fresh CVS checkout with recent
gnulib.  The latter is especially worrying because it implies
that gnulib didn't work at all (gl_INIT is implemented by

I *think* that the gl_INIT didn't fail until I ran gnulib manually.

> ERROR:  
> undefined reference to `_g_file_set_contents'
> src/ui/gui/src_ui_gui_psppire-syntax-editor.o(.text+0x902):syntax-editor.c:
> undefined reference to
> `_gtk_file_chooser_set_do_overwrite_confirmation'
> FIX/HACK: This was caused by the old version of glib (2.6.6) I was
> linking against. I just commented these out. This hack is clearly not
> something would want to release into the wild.  Perhaps configure
> should simply choke on old versions of glib?

Definitely.  Do you happen to know the versions in which these
functions were introduced?  It sounds like we should update the

g_file_set_contents was added in 2.8.

However gtk_file_chooser_set_do_overwrite_confirmation looks like a
Gtk problem. Since I was linking against the latest version (2.6.10)
of Gtk that does not require Cairo, perhaps configure should check for
this one function and do something suitable if it is not found.

> ERROR:  (psppire.exe:8): Pango-WARNING **: All font failbacks failed!!!!
>    wine i386-mingw32msvc/bin/fc-cache.exe -v
>    wine i386-mingw32msvc/bin/fc-list.exe -v

Is this a PSPP bug or is it a misconfiguration in mingw32 or

Its not so much a bug as something we will have to do in "setup.exe".

> ERROR: Make check complained that could not find libplot2.dll
> FIX/HACK: Copied libplot2.dll to src/ui/terminal.

That reminds me: I couldn't figure out how to get wine to search
arbitrary directories for libraries.  I tried setting WINEDLLPATH
but it didn't seem to have an actual effect, so (like you) I
ended up copying the libraries I needed into src/ui/terminal.  Is
there some kind of trick to WINEDLLPATH?

This problem only started occurring recently. I suspect that I
shouldn't have to set the "WINEDLLPATH" if everything links together
properly.  This could have been caused by the plot -dev and -lib
packages being missing from the target when I linked the executable
this time. I can test some more tonight.

John C. McCabe-Dansted
PhD Student
University of Western Australia

reply via email to

[Prev in Thread] Current Thread [Next in Thread]