[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

More compile problems with mingw

From: John McCabe-Dansted
Subject: More compile problems with mingw
Date: Wed, 14 Feb 2007 23:36:10 +0900

OK, I've tried building psppire against Gtk 2.6.10:
The plus side is that unlike Gtk 2.10, wine doesn't suffer from
The minus side is that most things show up as black boxes... I can get
Psppire to bascially work under Windows XP, but under wine the display
seems horribly corrupted regardless of what I do.  Things I've tried
(under both versions of Gtk) that didn't help:
 - Changing the emulated windows version between 95/98/2000/XP
 - upgrading wine (0.9.9->0.9.30)
 - removing all modules from my xorg.conf
Things I haven't tried
 - running Psppire.exe on a linux/wine machine that supports OpenGL.


I have also come across yet more build problems. A quick question: Is
it productive for me to report my build problems here? E.g. Are these
problems mostly already known, or is there a   better place I should
post them, such as the bug tracker?


ERROR: src/ui/gui/src_ui_gui_psppire-helper.o(.text+0x2fd): In
function `reference_manual':
/usr/src/pspp/pspp/src/ui/gui/helper.c:137: undefined reference to

FIX/HACK: I worked around error my  compile error by commenting out
the _g_spawn_command_line_async, which is used to start yelp.

ERROR:  i386-mingw32msvc-gcc: plural.c: No such file or directory

FIX/HACK: Copy plural.c from a previous pspp build tree.

ERROR:  src/data/file-name.c:31:26: canonicalize.h: No such file or directory
src/data/file-name.c: In function `fn_get_identity':
src/data/file-name.c:408: warning: implicit declaration of function
src/data/file-name.c:408: error: `CAN_MISSING' undeclared (first use
in this function)
src/data/file-name.c:408: error: (Each undeclared identifier is
reported only once
src/data/file-name.c:408: error: for each function it appears in.)
src/data/file-name.c:408: warning: initialization makes pointer from
integer without a cast

FIX/HACK: ../gnulib/gnulib-tool --import --dir=. --lib=libgl
--source-base=gl --m4-base=gl/m4 --doc-base=gl/doc --aux-dir=.
--libtool --macro-prefix=gl alloca alloca-opt assert byteswap c-ctype
c-strtod exit full-read full-write gethostname getline getlogin_r
getopt gettext intprops inttostr linebreak localcharset memcasecmp
memchr memcmp memmem memmove mempcpy memset progname readlink snprintf
stat-macros stdarg stdbool stdint stpcpy strcase strcspn strerror
strftime strsep strstr strtod strtok_r strtol strtoul unistd
unlocked-io vsnprintf xalloc xalloc-die xreadlink xsize xstrndup
xvasprintf canonicalize mbchar mbiter

ERROR:  make: *** No rule to make target `gl/m4/strstr.m4', needed by
`'.  Stop.

FIX/HACK: According to gnulib docs, strstr is pointless since
everybody implements it correctly, and has hence been removed. Fooled
make with a good 'ol:
       echo > gl/m4/strstr.m4

ERROR: configure: line 28215: gl_INIT: command not found

FIX/HACK: No fix, I just worried about it. If I ignore it, it doesn't
seem to cause any trouble

undefined reference to `_g_file_set_contents'
undefined reference to

FIX/HACK: This was caused by the old version of glib (2.6.6) I was
linking against. I just commented these out. This hack is clearly not
something would want to release into the wild.  Perhaps configure
should simply choke on old versions of glib?

ERROR:  (psppire.exe:8): Pango-WARNING **: All font failbacks failed!!!!

   wine i386-mingw32msvc/bin/fc-cache.exe -v
   wine i386-mingw32msvc/bin/fc-list.exe -v

ERROR: Make check complained that could not find libplot2.dll

FIX/HACK: Copied libplot2.dll to src/ui/terminal.

John C. McCabe-Dansted
PhD Student
University of Western Australia

reply via email to

[Prev in Thread] Current Thread [Next in Thread]