[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ranger-users] Version 1.5.0 out

From: Roman Z.
Subject: Re: [Ranger-users] Version 1.5.0 out
Date: Thu, 13 Oct 2011 18:46:58 +0200
User-agent: Mutt/1.5.21 (2010-09-15)


> After I install ranger with "sudo make install" I get still get this:
> ranger
> Can't import the main module.
> To run an uninstalled copy of ranger,
> launch ranger.py in the top directory.
> Traceback (most recent call last):
>   File "/usr/local/bin/ranger", line 52, in <module>
>     sys.exit(ranger.main())
> AttributeError: 'module' object has no attribute 'main'
> I have to symlink to ranger.py in the install directory to make it run. Is 
> there a way to correct this?

This happens when python can't find ranger's module.  When you run "sudo
make install", it should be installed properly and this should never
happen, so I dunno...

Can you tell me what do you mean with "install directory"?

> I also have added some mappings in rc.co$nf that worked before, but now gives 
> the error "Global name 'parse' is not defined". Is there something to be done 
> with this error?

As ranger changes, the configs change.  It seems like you copied the
default configs to ~/.ranger/config/ a while ago and didn't update them.

This specific error is due to an old commands.py.

If you didn't change the commands.py, simply delete it:
    rm ~/.config/ranger/commands.py*

If you did make changes, follow these steps:
1. open ~/.config/ranger/commands.py in an editor.
2. remove all default commands that you did not change, keep custom
   commands only.
3. if the custom commands don't work, take a look at the changelog and
   convert them manually

reply via email to

[Prev in Thread] Current Thread [Next in Thread]