[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ranger-users] Version 1.5.0 out

From: Jostein Berntsen
Subject: Re: [Ranger-users] Version 1.5.0 out
Date: Thu, 13 Oct 2011 19:22:52 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

On 13.10.11,18:46, Roman Z. wrote:
> Hi
> > After I install ranger with "sudo make install" I get still get this:
> > 
> > ranger
> > Can't import the main module.
> > To run an uninstalled copy of ranger,
> > launch ranger.py in the top directory.
> > Traceback (most recent call last):
> >   File "/usr/local/bin/ranger", line 52, in <module>
> >     sys.exit(ranger.main())
> > AttributeError: 'module' object has no attribute 'main'
> > 
> > I have to symlink to ranger.py in the install directory to make it run. Is 
> > there a way to correct this?
> This happens when python can't find ranger's module.  When you run "sudo
> make install", it should be installed properly and this should never
> happen, so I dunno...
> Can you tell me what do you mean with "install directory"?

The install directory is f.ex. 

~/dw/ranger-master> ls
build  CHANGELOG  COPYING  doc  INSTALL  install_log.txt  Makefile  ranger  
ranger.py  README  scripts  setup.py  test

> > I also have added some mappings in rc.co$nf that worked before, but now 
> > gives 
> > the error "Global name 'parse' is not defined". Is there something to be 
> > done 
> > with this error?
> As ranger changes, the configs change.  It seems like you copied the
> default configs to ~/.ranger/config/ a while ago and didn't update them.
> This specific error is due to an old commands.py.
> If you didn't change the commands.py, simply delete it:
>     rm ~/.config/ranger/commands.py*

This worked great, thanks!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]