[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug binutils/273] FAIL: size -A

From: nickc at redhat dot com
Subject: [Bug binutils/273] FAIL: size -A
Date: 26 Jul 2004 14:03:26 -0000

------- Additional Comments From nickc at redhat dot com  2004-07-26 14:03 
Subject: Re:  FAIL: size -A

Hi Dave,

>>Which compiler are you using ?

> The report was with gcc (GCC) 3.4.0.  I tried 3.3.3, 3.5.0 20040610,
> and HP "cc -Ae", all with the same result.  I also tried 3.5.0 at
> -O0.
> All the compiler builds that I have installed have had a full bootstrap
> and check prior to installation.  Given that the problem occurs both with
> GCC and HP cc, it seems unlikely that this is a host compiler bug.
> I don't know much about 3.2-gnupro-03r1-3 but I do know the main cvs
> versions contain a substantial number of fixes relative to 3.2.  The
> 3.3 branch is currently the main build compiler for the debian and
> gentoo parisc-linux ports, so it has received quite a bit of real-world
> testing.

OK then, lets assume that it is a binutils bug which for some reason is 
not being exposed by the gcc 3.2 based compiler I am using. 
Unfortunately this means that I am not going to be able to debug the 
problem myself.

I could send you the *.o files from my bfd and binutils directories. 
Maybe these could allow you to verify that a) they build a working 
'size' program and b) isolate which file(s) are broken ?


PS.  Just a shot in the dark here: if you try recompiling the bfd and 
binutils sources with -fno-unit-at-a-time does the problem go away ?



------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]