[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug in gnulib-tools prevents bison from bootstrapping

From: Fernando Ferreira
Subject: Re: Bug in gnulib-tools prevents bison from bootstrapping
Date: Fri, 22 Jun 2007 13:27:23 +0100
User-agent: Thunderbird (X11/20070525)

Hans Aberg wrote:
On 22 Jun 2007, at 13:42, Fernando Ferreira wrote:

Greetings, fellow developers!

I'm trying to compile bison from CVS, but it keeps failing at bootstrap phase. Here is what I'm doing:

   cvs -d:pserver:address@hidden:/sources/bison co bison
   cd bison/

And here is the error message it is giving me in the (abrupt) end of the process:

configure.ac:101: error: ` ' is already registered with AC_CONFIG_FILES.
   ../../lib/autoconf/status.m4:300: AC_CONFIG_FILES is expanded from...
   m4/gnulib-comp.m4:36: gl_INIT is expanded from...
   configure.ac:101: the top level
   autom4te: /usr/bin/m4 failed with exit status: 1
   aclocal: autom4te failed with exit status: 1

Autoconf requires the latest m4, but it actually calls gm4 it seems. So I installed the latest M4, which ended up in /usr/local/bin/m4 on my system, and added a soft link
  /usr/local/bin/gm4 -> /usr/local/bin/m4
Then it worked.

  Hans Aberg

Well, I saw that thread when I was looking up for possible solutions, but that is not the same problem you had in http://www.nabble.com/Re:-Installing-Bison-from-CVS-p10235415.html This one is a different one, and I solved it already, the description of the solution is in my original email :-D It was really a bug on gnulib-tools, I suppose, a mis-escaped backslash.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]