[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug in gnulib-tools prevents bison from bootstrapping

From: Hans Aberg
Subject: Re: Bug in gnulib-tools prevents bison from bootstrapping
Date: Fri, 22 Jun 2007 15:37:29 +0200

On 22 Jun 2007, at 14:55, according to Eric Blake:

According to Hans Aberg on 6/22/2007 6:13 AM:
Autoconf requires the latest m4, but it actually calls gm4 it seems. So
I installed the latest M4, which ended up in /usr/local/bin/m4 on my
system, and added a soft link
  /usr/local/bin/gm4 -> /usr/local/bin/m4
Then it worked.

Autoconf finds a working version of GNU m4 as part of its installation
process.  On your machine, it must have found that gm4 was the correct
name for the GNU m4 that was installed at the time you configured
autoconf. Alternatives to your symlink proposal, which are somewhat more
kosher for system maintainers,

I am not sure the above explanation holds up, because I think I had a /usr/local/bin/m4 long before I had a /usr/local/bin/autoconf, and others on the Bison list experienced the same problem, but could not find its origin.

would be either reconfiguring and
reinstalling autoconf after you installed the more recent GNU m4,

I feel fairly sure I tried that, and it did not help.

or using
the --program-prefix=g option of m4's configure script to install m4 as gm4.

My system has a /usr/bison/m4 and a /usr/bin/gm4, but no /usr/local/ bin/gm4, because later version of M4 odes not install it. So you need to check what exactly autoconf does, like simply trying to find gm4 before trying m4, which would be wrong.

  Hans Aberg

reply via email to

[Prev in Thread] Current Thread [Next in Thread]