[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Export archive and import it on another machine

From: 白い熊@相撲道
Subject: Re: Export archive and import it on another machine
Date: Fri, 19 Feb 2016 09:42:59 +0000

On February 18, 2016 11:34:52 PM CET, Leo Famulari <address@hidden> wrote:
>On Thu, Feb 18, 2016 at 08:01:44PM +0000, 白い熊@相撲道 wrote:
>> I'm trying to export Libreoffice from one PC and import it on another
>one — the reason I'm doing this is that with the latest git checkout
>when I try to install it on a PC with a newly installed GuixSD it keeps
>building it from source and failing. 
>> Anyhow, on the machine that I have it installed I ran: 
>> # guix archive --generate-key
>> $ guix archive --export -r /gnu/store/hash...libreoffice- >
>> Then copied the nar and /etc/guix/ to the other PC. 
>> There I ran: 
>> # guix archive --authorize <
>> $ guix archive --import < libreoffice-
>> The last command fails with: 
>> guix archive: error: build failed: program `guix-authenticate' failed
>with exit code 1
>> What am I doing wrong? 
>Hm, I'm not sure. Are you sure the source machine's public key is in

I think it is — I see one entry in the acl file, but since it's a hash I don't 
know how to confirm that it represents the much shorter hash found in the 
source machine's file. 

>> Side question — why is it building Libreoffice from source on “guix
>package -i libreoffice”? Recipe there, but not built on Hydra? How can
>I install an earlier already—built version? 
>Most likely for this reason:
>You can install an earlier version by checking out a commit in the Guix
>git repo from before Vigra broke, and building based on that commit

That's good — I can do that. I'm not really familiar with git yet — how can I 
determine the commit representing the point in time before Vitro broke and pull 
it? And how do I go back to master after rebuilding and installing libreoffice? 

>When building Guix from git, be sure to pass the correct value to
>./configure --localstatedir=. Most likely it is '/var'.

Thank you for reminding me of this! I would have forgotten for sure! :@) 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]