[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Export archive and import it on another machine

From: 白い熊@相撲道
Subject: Re: Export archive and import it on another machine
Date: Sat, 20 Feb 2016 11:25:22 +0000

On February 19, 2016 6:06:10 PM CET, Leo Famulari <address@hidden> wrote:
>On Fri, Feb 19, 2016 at 09:42:59AM +0000, 白い熊@相撲道 wrote:
>> On February 18, 2016 11:34:52 PM CET, Leo Famulari
><address@hidden> wrote:
>> >On Thu, Feb 18, 2016 at 08:01:44PM +0000, 白い熊@相撲道 wrote:
>> >> I'm trying to export Libreoffice from one PC and import it on
>> >one — the reason I'm doing this is that with the latest git checkout
>> >when I try to install it on a PC with a newly installed GuixSD it
>> >building it from source and failing. 
>> >> 
>> >> Anyhow, on the machine that I have it installed I ran: 
>> >> 
>> >> # guix archive --generate-key
>> >> $ guix archive --export -r /gnu/store/hash...libreoffice- >
>> >libreoffice- 
>> >> 
>> >> Then copied the nar and /etc/guix/ to the other PC.
>> >> 
>> >> There I ran: 
>> >> 
>> >> # guix archive --authorize <
>> >> $ guix archive --import < libreoffice-
>> >> 
>> >> The last command fails with: 
>> >> 
>> >> guix archive: error: build failed: program `guix-authenticate'
>> >with exit code 1
>> >> 
>> >> What am I doing wrong? 
>> >
>> >Hm, I'm not sure. Are you sure the source machine's public key is in
>> >/etc/guix/acl?
>> I think it is — I see one entry in the acl file, but since it's a
>hash I don't know how to confirm that it represents the much shorter
>hash found in the source machine's file. 
>Typically there would only be one entry in the acl file, containing
>'s public key.
>So, unless you do not use substitutes from, there should
>be two keys.
>Also, I believe that the imported key should match the contents of
> I tested this functionality while reading your message
>yesterday and that was my experience. Perhaps try importing the public
>key again?

Ugh — figured it out — this was dumb on my part. I was running “$ sudo guix 
archive --authorize <”, which obviously doesn't extend to input 
redirection — so nothing was authorized. 

Now I truly ran “# guix archive --authorize <”, it authorized 
the key. 

Then I was able to import libreoffice to the store — the directory is there.

However, it's not installed in my profile — “guix package -I” doesn't list it. 
Running “guix package -i libreoffice” again wants to rebuild it. How do I 
install the one that's been imported to the store?

>> >> Side question — why is it building Libreoffice from source on
>> >package -i libreoffice”? Recipe there, but not built on Hydra? How
>> >I install an earlier already—built version? 
>> >
>> >Most likely for this reason:
>> >
>> >
>> >You can install an earlier version by checking out a commit in the
>> >git repo from before Vigra broke, and building based on that commit
>> >[0].
>> That's good — I can do that. I'm not really familiar with git yet —
>how can I determine the commit representing the point in time before
>Vitro broke and pull it? And how do I go back to master after
>rebuilding and installing libreoffice? 
>I bet if you ask on #guix, somebody will know what broke Vigra and can
>help you figure that out. Otherwise, I would read the git log and
>compare it to Vigra's dependencies; you might find some clues. Then you
>can use `git bisect` to narrow it down.
>After installing libreoffice from that commit, you don't need to do
>anything special. You can keep using guix normally. Your working
>installation of libreoffice will remain in your profile until you can
>successfully update it from the HEAD of the master branch again (that
>is, with `guix pull`).
>> >When building Guix from git, be sure to pass the correct value to
>> >./configure --localstatedir=. Most likely it is '/var'.
>> Thank you for reminding me of this! I would have forgotten for sure!
>> --
>> 白い熊@相撲道
>> >[0]
>> >

reply via email to

[Prev in Thread] Current Thread [Next in Thread]