[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SOLVED!!!: Re: Help with CVSWeb

From: Alexander Kamilewicz
Subject: SOLVED!!!: Re: Help with CVSWeb
Date: Wed, 13 Jun 2001 08:34:03 -0500

Hi all!

I've solved my problem described in great detail below, and I thought
I'd share with you all so that you can all laugh at me.  :)

The problem:  After installing cvsweb (cvsweb.cgi & cvsweb.conf) via the
included instructions, the URL does
produce a webpage which lists the modules in my repository.  However,
when you click on any module you get a 404.

The hint:  The 404 page had a URL that looked like this:  It should have looked like this:  And in fact, if you typed in
the latter URL, you'd get a correct page.

The solution:  In fact, all cgi scripts are supposed to be executed from
the URL with the following syntax: 
NOTE the last forward slash.  Most webservers automatically take a URL
without the trailing forward slash and redirect to the correct URL. 
Basically my server (well, not mine, since I'm not the webserver admin)
doesn't do this. 

So now I'll just make a page with a link to the script that includes the
last forward-slash and everthing will be happy.


Alexander Kamilewicz wrote:
> Hi Karl,
> Karl-Heinz Marbaise wrote:
> >
> > Hi there,
> >
> >  The problem:  I'm trying to install cvsweb
> > > (, and it won't show
> > > anything below the initial cvs directory (see below for specifics).
> > Have you checked the permissions of the directories if they are world
> > readable?
> You betcha!
> > > 3.  Chucked cvsweb.cgi in cgi-bin, and cvsweb.conf into conf, and
> > > "icons" into cgi-bin (more on this later, a small problem)
> > Why not like the default as a point of start...
> I don't think I understand your question here.  Sorry.
> > > 5.  Modified cvsweb.cgi like so:
> > > $config = $ENV{'CVSWEB_CONFIG'} || '../conf/cvsweb.conf';
> > Why do you modify... The first step should to try as it was and get
> > it running...
> Well, we're running Netscape server, not Apache, and the default that
> comes with the distribution assumes Apache, so for that alone I had to
> change it.  The tree is kind of weird.  Unfortunately, it isn't my
> webserver, so I don't have control over it.  Here's the tree:
> http
>   |
> htdocs
>   |
>  foo
>   |_________________
>   |        |        |
> htdocs    conf     cgi-bin
> cvsweb.cgi is in cgi-bin and cvsweb.conf is in conf.
> > > i.e. the conf file is up out of cgi-bin, and down into conf.
> > If you use ".." then the cvsweb.conf have to be in ../conf directory
> > (one
> > level above cgi-bin. BTW have you set the permissions correct?
> Yep.  At this point they're all basically 777, because I'm getting
> desperate.  :)
> > > At this point I then tried to run the script.  It failed due to
> > > "unspecified variables".
> > I think the message have to be "uninitialized value..." within the
> > Apache error log file. If you have something different you should try
> > to install it in the default way and then change this defaults to your
> > needs.
> Well, this web server is Netscape, so I assume the errors are similar.
> As I said before, though, I got through all of this and got it to work,
> somewhat.  When I load up I see my
> repository & all of its modules.  However, when I click on a module I
> get a 404.
> I noticed in other cvsweb installations that when you click on a module
> your URL looks like this:
> Mine (on the 404 page) looks like this:
>  I.e. the "cvsweb.cgi" part of the URL
> has disappeared.
> This leads me to believe that there's some sort of config issue that is
> keeping the server from using cvsweb.cgi to "work" on the directories &
> create html pages for them.
> Do you think I'm on the right track here, or hopelessly lost?
> Thanks,
> Alex
> _______________________________________________
> Info-cvs mailing list
> address@hidden

This message is intended only for the use of the addressee(s) named
herein.  The information contained in this message is confidential and
may constitute proprietary or inside information.  Unauthorized review,
dissemination, distribution, copying or other use of this message,
including all attachments, is strictly prohibited and may be unlawful. 
If you have received this message in error, please notify us immediately
by return e-mail and destroy this message and all copies thereof,
including all attachments.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]