[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Unable to increment revision number

From: Christopher Cheng
Subject: RE: Unable to increment revision number
Date: Wed, 14 Sep 2005 00:41:59 +0800

Thanks for the guide, I will definitely try that. By the way, I tried to
edit the file myself. I am able to run 'cvs log -h'

RCS file: /cvsroot/espresso/web/WEB-INF/conf/struts-references.xml,v
Working file: struts-references.xml
head: 1.23
locks: strict
access list:
symbolic names:
keyword substitution: kv
total revisions: 24

However, 'cvs update -A' still doesn't get me 1.23. That's very strange. Any

-----Original Message-----
From: Larry Jones [mailto:address@hidden 
Sent: Wednesday, September 14, 2005 12:32 AM
To: Christopher Cheng
Cc: 'Jim Hyslop'; 'Dave Korn'; address@hidden
Subject: Re: Unable to increment revision number

Christopher Cheng writes:
> Oh... Could somebody guide me how to get check_cvs script? I am using
> and I could not find that in C:\Program Files\cvsnt. 

Look for validate_repo -- I forgot it had been renamed.  If you don't
have it, you can get it from the source distribution:


The file name there is -- normally, you would edit the
first line to have the path to perl (it's a perl script, you'll need to
get that, too, if you don't already have it), but since it appears
you're running on Windows, you'll probably just have to explicitly run
perl, so it won't matter.

> Could somebody guide me how to edit those files by hand (even removing
> revisions) so that my colleagues can continue to work on it for the time
> being?

Probably not.  Fixing a corrupted RCS file is a black art that requires
extensive knowledge of the RCS file structure and some way of recovering
the missing information.  If you have a recent backup that isn't also
corrupted, you should probably restore it.

-Larry Jones

Can I take an ax to school tomorrow for ... um ... show and tell? -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]