[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libtool doesn't allow "make DESTDIR=`pwd`/foo install" anymore.

From: Martin Norbäck
Subject: Re: libtool doesn't allow "make DESTDIR=`pwd`/foo install" anymore.
Date: 27 Nov 2001 17:39:02 +0100

tis 2001-11-27 klockan 15.54 skrev Rob Browning:
> If you build a package with --prefix=/usr and that package has
> interdependencies among it's shared libraries (like guile and
> heimdal), libtool will no longer allow you to install to a temporary
> directory via
>   make DESTDIR=`pwd`/foo install
> libtool 1.4 allowed this, but as of at least 1.4.2, it doesn't.  This
> makes it very difficult, if not impossible to package programs using
> libtool for systems like debian that require creating a local install
> from which the package is generated.

We have this problem with our package ogle as well. Libtool 1.4 allowed
this, but didn't do it correctly. I haven't tried libtool 1.4.2 yet.

See my mail to this list:

> See, bugs 57087 and 98342.

This seems to be the problem we have too.

> I also wanted to see if anyone had suggestions for a fix, even a
> temporary one.  There's a patch in the debian package that seems to
> fix the problem for some people, but still doesn't work for other
> package like guile and heimdal.

No, I have not found a solution to this problem. Our current approach
when building RPMS is to build the package twice, the second time with
the package partially installed. Not very good.



[ ] [ PGP: 0x453504F1 ] [ UIN:
4439498 ]
    Opinions expressed above are mine, and not those of my future
SIGBORE: Signature boring error, core dumped

reply via email to

[Prev in Thread] Current Thread [Next in Thread]