[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libtool doesn't allow "make DESTDIR=`pwd`/foo install" anymore.

From: Paul E Johnson
Subject: Re: libtool doesn't allow "make DESTDIR=`pwd`/foo install" anymore.
Date: Tue, 27 Nov 2001 10:38:37 -0600
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011014

I thought I had posted to the list earlier, but must have sent this to a specific person.

This libtool issue is a known and fixed problem in libtool cvs. I built rpms of that snapshot of libtool and I've tested it and it does work. If you want to try the RPMS, I stashed them in here

I do now know what patch is required to make libtool-1.4.2 work as it is currently released, I've been asking about. My understanding is that the Debian packager of libtool has a patch which fixes the problem.

I have tried taking the patch which was applied in cvs and applying it to libtool-1-4.2, but that caused segfaults when running programs that use libtool, so for the moment I'm running the libtool cvs snapshot from

I have no idea if this edition introduces new bugs or not, I wish I could run a minimally modified 1.4.2

Martin Norbäck wrote:

tis 2001-11-27 klockan 15.54 skrev Rob Browning:

If you build a package with --prefix=/usr and that package has
interdependencies among it's shared libraries (like guile and
heimdal), libtool will no longer allow you to install to a temporary
directory via

 make DESTDIR=`pwd`/foo install

libtool 1.4 allowed this, but as of at least 1.4.2, it doesn't.  This
makes it very difficult, if not impossible to package programs using
libtool for systems like debian that require creating a local install
from which the package is generated.

We have this problem with our package ogle as well. Libtool 1.4 allowed
this, but didn't do it correctly. I haven't tried libtool 1.4.2 yet.

See my mail to this list:

See, bugs 57087 and 98342.

This seems to be the problem we have too.

I also wanted to see if anyone had suggestions for a fix, even a
temporary one.  There's a patch in the debian package that seems to
fix the problem for some people, but still doesn't work for other
package like guile and heimdal.

No, I have not found a solution to this problem. Our current approach
when building RPMS is to build the package twice, the second time with
the package partially installed. Not very good.



Paul E. Johnson                       email: address@hidden
Dept. of Political Science  
University of Kansas                  Office: (785) 864-9086
Lawrence, Kansas 66045                FAX: (785) 864-5700

reply via email to

[Prev in Thread] Current Thread [Next in Thread]