lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Corrected comments and a function check_meshing_chords divided in tw


From: hanwenn
Subject: Re: Corrected comments and a function check_meshing_chords divided in two. (issue 5975054)
Date: Mon, 02 Apr 2012 01:03:40 +0000


http://codereview.appspot.com/5975054/diff/1/lily/include/note-collision.hh
File lily/include/note-collision.hh (right):

http://codereview.appspot.com/5975054/diff/1/lily/include/note-collision.hh#newcode56
lily/include/note-collision.hh:56: int down_ball_type;
this doesnt make sense?  The booleans classify the collision type, while
these ints are input data to the problem?  I think it is better to
separate input data and the rest.

http://codereview.appspot.com/5975054/diff/1/lily/include/note-collision.hh#newcode69
lily/include/note-collision.hh:69: down_ball_type(down_ball_type_) {}
drop this ctor: just have ctor that init everything to default values,
and then use

 ctype.full_collide = true

this is much easier to read, since the order of the 6 args is easy to
get wrong.

Is this data type really necessary, btw?

http://codereview.appspot.com/5975054/diff/1/lily/staff-symbol-referencer.cc
File lily/staff-symbol-referencer.cc (right):

http://codereview.appspot.com/5975054/diff/1/lily/staff-symbol-referencer.cc#newcode126
lily/staff-symbol-referencer.cc:126: * Returns vertical position of a
symbol relatively to the staff.
relative

http://codereview.appspot.com/5975054/diff/1/lily/staff-symbol-referencer.cc#newcode137
lily/staff-symbol-referencer.cc:137: * The unit is halves of staff
space.
was the official coding style for comments changed? If not, can you
avoid the leading *s ?

http://codereview.appspot.com/5975054/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]