[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] No throttle in Auto2

From: address@hidden
Subject: Re: [Paparazzi-devel] No throttle in Auto2
Date: Thu, 21 Aug 2008 20:05:28 GMT

Does your plane respond to modem commands?  Maybe it's just not getting the 
launch command?  Try changing the tuning gains and see if the values update.

-- "cory barton" <address@hidden> wrote:

I have done the ground based portion of the tuning procedure and
everything is going mostly ok. My one issue is that the motor will not
run in AUTO2 mode.

I think that a good thing to try before flying is to get a good grip
on the plane, and verify that the plane will throttle up, when the
flight plan is in the takeoff block, and the launch button is pressed.

I am using a modified version of the basic flight plan(see below). I
have eliminated everything except the takeoff, and blocks to circle
around STDBY, and waypoint 1. It works great in simulation.

When I turn on the AP, I have control of all the actuators in manual
mode, including throttle. The PFD reflects the actual attitude of the
plane. I also have full control in AUTO1 mode, and the control
surfaces appear to move correctly when I change the attitude of the
plane, and the throttle response is good.

However, when I switch to AUTO2, I cannot get the system to move out
of the holding point block, and the throttle area is red in the GCS. I
got a message in the GCS saying: "mayday, kill mode". I tried using
the settings under the misc tab to set kill_throttle to 0, but it
didn't work. No matter what I tried, I could not get the prop to spin
in AUTO2 mode.

Then I commented out the holding point block, and reflashed the AP.
The flight plan went directly from Geo init to takeoff, and the
throttle area was orange in the GCS. So I set the AP to AUTO2, and hit
the launch button. No response. I switched back to manual and auto1,
and the throttle works just fine. Switch to AUTO2, and no throttle.

Please let me know what I am missing.



<!DOCTYPE flight_plan SYSTEM "flight_plan.dtd">

<flight_plan alt="75" ground_alt="0" lat0="37.08253" lon0="-76.39815"
max_dist_from_home="700" name="Basic" security_height="25">
#include "nav_line.h"
#include "datalink.h"
    <waypoint name="HOME" x="0" y="0"/>
    <waypoint name="STDBY" x="120.6" y="115.6"/>
    <waypoint name="1" x="-45.5" y="174.2"/>
    <waypoint name="CLIMB" x="153.6" y="23.9"/>
    <block name="Wait GPS">
      <set value="1" var="kill_throttle"/>
      <while cond="!GpsFixValid()"/>
    <block name="Geo init">
      <while cond="LessThan(NavBlockTime(), 10)"/>
      <call fun="NavSetGroundReferenceHere()"/>
    <block name="Holding point">
      <set value="1" var="kill_throttle"/>
      <attitude roll="0" throttle="0" vmode="throttle"/>
    <block name="Takeoff" strip_button="Takeoff (wp CLIMB)"
      <exception cond="estimator_z > ground_alt+25" deroute="Standby"/>
      <set value="0" var="kill_throttle"/>
      <set value="0" var="estimator_flight_time"/>
      <go from="HOME" pitch="15" throttle="1.0" vmode="throttle" wp="CLIMB"/>
    <block name="Standby" strip_button="Standby" strip_icon="home.png">
      <circle radius="nav_radius" wp="STDBY"/>
    <block name="Circle 1" strip_button="Circle 1"
      <circle radius="nav_radius" wp="1"/>

Paparazzi-devel mailing list

Click here for a free directory of employee development and training solutions.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]