[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [patch #5562] line-buffer / getl_ reorganisation

From: John Darrington
Subject: Re: [patch #5562] line-buffer / getl_ reorganisation
Date: Wed, 29 Nov 2006 14:25:36 +0800
User-agent: Mutt/1.5.9i

On Wed, Nov 29, 2006 at 05:37:32AM +0000, Ben Pfaff wrote:
     In prompt.[ch], could the functions be renamed to put "prompt" at the
     beginning?  e.g. get_prompt_style -> prompt_get_style and so on.  This
     would make it clear at a glance that they come from a module named

     I think that the function source is only used in DO REPEAT.  I wonder
     whether it should be merged in with it.  It seems like the
     function_source is a really thin wrapper around getl_interface now; it
     was less apparently "thin" before, because it *was* the exposed

You're right.  I'll make struct repeat_block implement
getl_interface.  That will mean that function.[ch] is not needed, and
will be much neater.


PGP Public key ID: 1024D/2DE827B3 
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See or any PGP keyserver for public key.

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]