[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: running tests under in a tests/ directory

From: aaragon
Subject: Re: running tests under in a tests/ directory
Date: Tue, 9 Jun 2009 11:56:19 -0700 (PDT)

Ralf, one more thing. I tried to move the tests to a different library and I
am having problems with the linking part. The undefined symbols are from the
library that I'm trying to build using the Autotools.

In the test/ I tried adding 

AM_LDFLAGS = -L$(top_srcdir)/yafeq

LIBS += -lyafeq

but this doesn't work, it seems that it enters an infinite loop when
linking. How do you solve this? 


Ralf Wildenhues wrote:
> * aaragon wrote on Fri, Jun 05, 2009 at 09:05:18PM CEST:
>> When deliberately making the tests fail, I still get:
>> address@hidden/Documents/workspace/cpputils$make check
>> Making check in cpputils
>> make[1]: Nothing to be done for `check'.
>> Making check in tests
>> make  check-TESTS
>> FAIL: test001
>> PASS: testcppblas
>> ==============================================================
>> 1 of 2 tests failed
>> See tests/test-suite.log
>> Please report to Alejandro Aragon <address@hidden>
>> ==============================================================
>> make[3]: *** [test-suite.log] Error 1
>> make[2]: *** [check-TESTS] Error 2
>> make[1]: *** [check-am] Error 2
>> make: *** [check-recursive] Error 1
>> and I removed the double quoting from the AC_INIT macro already.
> This looks normal, and expected to me, given that you put your name and
> address in the third argument of AC_INIT.  What do you consider
> unexpected here?
>> One more comment. You forgot to add the diff-driver file to the
>> variable.
> Thanks!  I'm sure Martin will like to fix this on his web page then.
> Cheers,
> Ralf

View this message in context:
Sent from the Gnu - Automake - General mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]