[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Frustration

From: Stanley A. Klein
Subject: Re: Frustration
Date: Wed, 16 Oct 2002 18:56:23

Jason -

My other comments are interspersed, but your last suggestion seems to have
helped me isolate what I now think is the problem.  I think it is related
to how Red Hat configures Postgresql.  The access for language API's is
through port 5432.  I probably need to figure out how to create a configure
string for connections.conf that will accomplish that kind of connection.

At 09:29 PM 10/14/2002 -0500, Jason Cater wrote:
>My recommendation to you is to either do a real installation, where you
>untar each package and run it's, or install a CVS copy.  If this
>mutated install you are trying is not working, this would definitely be my
>next step!

Actually, I'm going to continue using the "mutated install" until I'm
convinced the problem is in the install.  Right now I think it is as
discussed above.

>A few things regarding the dbdrivers.  Personally, I would grab psycopg
>from It is better tested. We state this in the mailing
>lists whenever we get a chance. I use it in production, as do most of the
>other developers. You can certainly use pypgsql, but as you seem
>frustrated, why go against the flow? 

The psycopg driver only comes packaged in deb format.  I can't use that
directly.  I understand there is a program called "alien" that converts
back and forth between rpm and deb formats.  I downloaded it but haven't
installed it or tried it.  I won't install from tarballs in root-controlled
areas, because I lose configuration control of my system that way.

>Have you installed Egenix's mx-base package.  Most of the dbdrivers
>(pypgsql included) need mxdatetime internally. This is available from:   

The mx package has a link in the same python site-packages directory as the

>Have you looked through the lists for RedHat support? I know we have at
>least one RedHat HOWTO. 

I should probably check this to see if it has the solution to the problem I
think I have.  However, my problem is related to a problem that Alesandro
Bottoni reported on the list in late September.  I think he is trying to
solve the same problem in Forms that I am having in Designer.  I haven't
seen any message from him saying he solved it, but he might have solved it
and not reported his solution.

>Have you tried to manually import your pypgsql package? 
>  # python
>  >>> from pyPgSQL import PgSQL

Bingo!! This diagnostic got me an error message (something about a shared
object not being open, IIRC) that appears related to not connecting to the
port.  (I saw something somewhere that suggests that kind of message
relates to that issue.)

>Does that fail? If so, PyPgSQL isn't installed properly. If not, I imagine
>it has something to do with mxDateTime. 

I think it is installed properly, although they talk in the docs about a that I don't have in the distribution that sets up something (but
maybe was run in preparing the rpm package).  I may need to get the tarball
and see what it is.  I think the driver just isn't being given the right
parameters in the right format to make the connection.  I'm working on
trying to find the right parameters and format.  There are some test
programs in /usr/share for the driver.  I tried one of them and got a
similar error.  

I think the "connection" (string) parameter in connections.conf is what I
will need to use.  It might also help to have a "port" parameter, but I
want to get things working somehow before I suggest that.

>Incidentally, if you do ever manage to get us a showing at something like
>the e-gov conference, let's get you setup before the demo date!

Well, there is another e-gov conference (state and local focus) planned for
next March.  BTW, I attended the first day of this one today.  There is
also the Maryland Tech Showcase in December, but I haven't heard anything
from anybody on my request for interest in setting up a free/open-source

Stan Klein

>On Mon, 14 Oct 2002 18:23:39
>"Stanley A. Klein" <address@hidden> wrote:
>> Right now, I'm finding that getting GNUe to do anything useful is an
>> exercise in total frustration.  I have by now installed both pypgsql and
>> pygresql.  I set up a database structure using pgaccess, so a database
>> would be there to work with.  
>> No matter what I do, when I start Designer and try to connect to the
>> database, all I get is a message that the database driver isn't there. 
>> I have checked every which way I know how and I see the database drivers
>> where I think they are supposed to be.  The pypgsql driver has a .pyc
>> file with it, so I know something has been happening there.
>> I'm glad we didn't get selected to do a demo at the e-government
>> conference this week or I would have had to cancel it.
>> I'm using the quasi-cvs install I described in a previous email to the
>> list.  My system is pretty much a straightforward Red Hat 7.2 with some
>> outside rpm packages added and updated (such as wxPython, etc.).  
>> Does anyone have any ideas on what to try to get this thing to work?
>> Stan Klein
>> _______________________________________________
>> Gnue mailing list
>> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]